#40647 [Opn->Fbk]: ldap_connect() fails when restarting Apache 2.0.55 via restart or graceful

From: Date: Mon, 26 Feb 2007 18:22:53 +0000
Subject: #40647 [Opn->Fbk]: ldap_connect() fails when restarting Apache 2.0.55 via restart or graceful
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-109591@lists.php.net to get a copy of this message
ID: 40647 Updated by: tony2001@php.net Reported By: csi92 at yahoo dot com -Status: Open +Status: Feedback Bug Type: LDAP related Operating System: Red Hat Enterprise Linux AS rele PHP Version: 4.4.5 New Comment: Check your error_log. Previous Comments: ------------------------------------------------------------------------ [2007-02-26 18:10:41] csi92 at yahoo dot com Description: ------------ I am connecting to an iPlanet LDAP. After starting Apache via ./apachectl start, the ldap_connect() function works fine. If I stop and start Apache via ./apachectl stop, ./apachectl start, the ldap_connect function works fine. If I restart Apache via ./apachectl restart OR ./apachectl graceful, the ldap_connect function fails and the page is blank. The page source is blank. With error reporting -- ini_set('error_reporting', E_ALL); -- No errors are reported. If I stop/start Apache again via ./apachectl stop, ./apachectl start, the ldap_connect function works fine again. Reproduce code: --------------- <?php ini_set('error_reporting', E_ALL); $ds=ldap_connect("directory.fedex.com"); // prepare to connect to ldap if ($ds) { echo "<p>LDAP Connection Successful<p>"; $r=ldap_bind($ds); // this is an "anonymous" bind $sr=ldap_search($ds, "o=fedex, c=US", "uid=322049"); // Search for "ovis" UID $info = ldap_get_entries($ds, $sr); // Get entries ldap_close($ds); // Close connection }else{ echo "<h4>Unable to connect to LDAP server</h4>"; } ?> Expected result: ---------------- LDAP Connection Successful Actual result: -------------- When I stop and start Apache using ./apachectl stop and then ./apachectl startssl I get "LDAP Connection Successful". When us stop and start Apache using either ./apachectl restart or ./apachectl graceful I get a blank page. When I view source, it is blank also. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=40647&edit=1

« previous php.bugs (#109591) next »