#40647 [Opn]: ldap_connect() fails when restarting Apache 2.0.55 via restart or graceful
| From: | csi92 at yahoo dot com | Date: | Mon, 26 Feb 2007 19:26:32 +0000 |
| Subject: | #40647 [Opn]: ldap_connect() fails when restarting Apache 2.0.55 via restart or graceful | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-109601@lists.php.net to get a copy of this message | ||
ID: 40647
User updated by: csi92 at yahoo dot com
Reported By: csi92 at yahoo dot com
Status: Open
Bug Type: LDAP related
Operating System: Red Hat Enterprise Linux AS rele
PHP Version: 4.4.5
New Comment:
After running the script in the browser and it did NOT work, I tried
running the same script from the command line (php zzz.php) and it
worked at the command line.
Previous Comments:
------------------------------------------------------------------------
[2007-02-26 19:09:16] csi92 at yahoo dot com
Where is the core file supposed to be generated?
Also, the instructions are referring to 1.x.x of Apache instead of
2.0.x. There is no sbin directory in our Apache 2.0.55 installation.
------------------------------------------------------------------------
[2007-02-26 18:32:25] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php
for Win32
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
------------------------------------------------------------------------
[2007-02-26 18:31:02] csi92 at yahoo dot com
When I restart Apache via .apachectl restart I get the following in the
Apache error log:
[Mon Feb 26 12:26:08 2007] [notice] SIGHUP received. Attempting to
restart
[Mon Feb 26 12:26:10 2007] [warn] RSA server certificate CommonName
(CN) `viplabser14.intranet.XXXXXX.com' does NOT match server name!?
[Mon Feb 26 12:26:11 2007] [notice] Apache configured -- resuming
normal operations
When I then execute the code in a browser, I get the following notice
in the Apache error log:
[Mon Feb 26 12:26:26 2007] [notice] child pid 28463 exit signal
Segmentation fault (11)
------------------------------------------------------------------------
[2007-02-26 18:22:53] tony2001@php.net
Check your error_log.
------------------------------------------------------------------------
[2007-02-26 18:10:41] csi92 at yahoo dot com
Description:
------------
I am connecting to an iPlanet LDAP. After starting Apache via
./apachectl start, the ldap_connect() function works fine.
If I stop and start Apache via ./apachectl stop, ./apachectl start, the
ldap_connect function works fine.
If I restart Apache via ./apachectl restart OR ./apachectl graceful,
the ldap_connect function fails and the page is blank. The page source
is blank. With error reporting -- ini_set('error_reporting', E_ALL); --
No errors are reported.
If I stop/start Apache again via ./apachectl stop, ./apachectl start,
the ldap_connect function works fine again.
Reproduce code:
---------------
<?php
ini_set('error_reporting', E_ALL);
$ds=ldap_connect("directory.fedex.com"); // prepare to connect to
ldap
if ($ds) {
echo "<p>LDAP Connection Successful<p>";
$r=ldap_bind($ds); // this is an "anonymous" bind
$sr=ldap_search($ds, "o=fedex, c=US", "uid=322049"); // Search for
"ovis" UID
$info = ldap_get_entries($ds, $sr); // Get entries
ldap_close($ds); // Close connection
}else{
echo "<h4>Unable to connect to LDAP server</h4>";
}
?>
Expected result:
----------------
LDAP Connection Successful
Actual result:
--------------
When I stop and start Apache using ./apachectl stop and then
./apachectl startssl I get "LDAP Connection Successful".
When us stop and start Apache using either ./apachectl restart or
./apachectl graceful I get a blank page. When I view source, it is
blank also.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40647&edit=1