Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on
| From: | derick@php.net | Date: | Tue, 18 Jun 2002 08:00:24 +0000 |
| Subject: | Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11038@lists.php.net to get a copy of this message | ||
ID: 13595
Updated by: derick@php.net
Reported By: plafundum@yahoo.com
-Status: Analyzed
+Status: Closed
Bug Type: Session related
Operating System: Debian Sid
PHP Version: 4.0.6
New Comment:
This is most likely fixed in the latest version. Please reopen if PHP
4.2.1 doesn't fix the problem.
Previous Comments:
------------------------------------------------------------------------
[2002-06-12 22:15:51] supers@starblaze.2y.net
I get
fstat64(3, {st_mode=S_IFREG|0644, st_size=1748, ...}) = 0
unlink("/tmp/session_mm_apache0.sem") = -1 ENOENT (No such file or
directory)
before it dies, any idea? (using debian linux)
------------------------------------------------------------------------
[2002-04-24 17:18:41] 2002@gabrielwicke.de
Sorry,
i forgot to mention my settings:
session handler is 'files', location for those /tmp- my php.ini is
completely unchanged from the defaults sessionwise.
------------------------------------------------------------------------
[2002-04-24 17:15:48] 2002@gabrielwicke.de
I'm experiencing a similar problem after updating to php 4.1.0-104
(from the SUSE 8.0 Distro). Whenever i try to call php as a cgi ftp
server i now get this:
Content-type: text/html
PHP Fatal error: Unable to start session mm module in Unknown on line
0
i did a locate .sem and it showed one file at
/var/lib/httpd/mm.1257.sem. Deleting that didn't help.
The ftp loader worked perfect with the previous version (4.0something),
and the trouble with the new version appears only when calling php as
cgi.
Any ideas?
------------------------------------------------------------------------
[2002-03-07 15:08:30] matt@mystile.com
Yes, I had the save path explicitly set to '/dev/null' in php.ini since
I first installed version 4.0.5; I haven't been using sessions, so I
wouldn't have noticed if sessions were not working. However, after the
upgrade, I sure noticed something was wrong, since apache wouldn't
start.
As for why it was setup that way... I have the server setup so each
virtual host uses its own 'tmp' directory, and as I recall, I didn't
want PHP to store anything in '/tmp'.
------------------------------------------------------------------------
[2002-03-07 00:30:14] mfischer@php.net
Ah .. interesting ...
Did you set the save path explicitely to '/dev/null' ? (And if so,
why?)
All I know at the moment is that serveral session issues are adressed
at the moment. Marking this as analyzed until one of our session gurus
can answer this more accurat.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/13595
--
Edit this bug report at http://bugs.php.net/?id=13595&edit=1