Bug #12336 Updated: Unable to load dynamic library liboci8.so

From: Date: Tue, 18 Jun 2002 09:37:00 +0000
Subject: Bug #12336 Updated: Unable to load dynamic library liboci8.so
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-11086@lists.php.net to get a copy of this message
ID: 12336 Updated by: derick@php.net Reported By: Pavel.Zakouril@mff.cuni.cz -Status: Open +Status: Feedback Bug Type: OCI8 related Operating System: SCO UnixWare 7.1.1 PHP Version: 4.0.6 New Comment: please try the latest CVS snapshot from snaps.php.net and report back if it fixes the problem for you. Derick Previous Comments: ------------------------------------------------------------------------ [2001-07-24 09:26:36] Pavel.Zakouril@mff.cuni.cz I am trying to get working oci8 as a dynamic (shared) module. When I build a static oci8 support, everything works fine. But when I switch to dynamic: export CC=cc; ./configure --with-oci8=shared --with-apxs -without-mysql compilation and installations proceeds O.K., but when I try to load liboci8.so in my PHP script, I obtain the following message: Warning: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20001222/liboci8.so' - dynamic linker: /usr/local/sbin/httpd: relocation error: symbol not found: lio_listio64; referenced from: /u01/app/oracle/product/8.1.6/lib/libclntsh.so.8.0 in /usr/www/mff/oratest.htm on line 26 What can be wrong ? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=12336&edit=1

« previous php.bugs (#11086) next »