Bug #17829: undefined symbol: __dn_expand

From: Date: Wed, 19 Jun 2002 04:53:24 +0000
Subject: Bug #17829: undefined symbol: __dn_expand
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-11333@lists.php.net to get a copy of this message
From: skraj@telocity.com Operating system: Debian Linux 2.2.20 PHP version: 4.2.1 PHP Bug Type: *Configuration Issues Bug description: undefined symbol: __dn_expand I compiled and installed php using the following: $ ./configure --prefix=/usr/local/php --with-apxs=/usr/local/apache/bin/apxs $ make $ make install Everthing went fine. When I started Apache I got the following error message: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: __dn_expand bin/apachectl start: httpd could not be started I tried several suggestions from newsgroups to recompile and reinstall php; however, I keep getting the same error message. I am using apache 1.3.24. Help please! -- Edit bug report at http://bugs.php.net/?id=17829&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17829&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17829&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17829&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17829&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17829&r=support Expected behavior: http://bugs.php.net/fix.php?id=17829&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17829&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17829&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17829&r=globals

« previous php.bugs (#11333) next »