#41779 [NEW]: ftp_nlist() and ftp_rawlist() fail with open_basedir
| From: | derernst at gmx dot ch | Date: | Fri, 22 Jun 2007 14:18:09 +0000 |
| Subject: | #41779 [NEW]: ftp_nlist() and ftp_rawlist() fail with open_basedir | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-114087@lists.php.net to get a copy of this message | ||
From: derernst at gmx dot ch
Operating system: Linux
PHP version: 5.2.3
PHP Bug Type: Safe Mode/open_basedir
Bug description: ftp_nlist() and ftp_rawlist() fail with open_basedir
Description:
------------
After my ISP upgraded to PHP 5.2.3 (sorry I don't know from which previous
version), functions ftp_nlist() and ftp_rawlist() stopped working:
PHP Warning: ftp_nlist() [function.ftp-nlist]: open_basedir restriction in
effect. File(/var/tmp/) is not within the allowed path(s):
(/data/htdocs/domain.com/:/usr/local/share/pear/:/tmp/:/var/tmp/) in ...
Note that the required path does actually match an allowed paths entry:
- File(/var/tmp/)
- allowed path(s):
(/data/htdocs/domain.com/:/usr/local/share/pear/:/tmp/:/var/tmp/)
I found several bugs that might be related to this one, see bugs nr.
40141, 41518, 41684; bug 13720 describes the same phenomenon but assumably
for an other reason.
The functions work again after my ISP removed the trailing slashes from
the open_basedir entries. This can't be a desirable solution, though!
--
Edit bug report at http://bugs.php.net/?id=41779&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=41779&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=41779&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=41779&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=41779&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=41779&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=41779&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=41779&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=41779&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=41779&r=support
Expected behavior: http://bugs.php.net/fix.php?id=41779&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=41779&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=41779&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=41779&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=41779&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=41779&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=41779&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=41779&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=41779&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=41779&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=41779&r=mysqlcfg