#41779 [Opn->Fbk]: ftp_nlist() and ftp_rawlist() fail with open_basedir
| From: | tony2001@php.net | Date: | Mon, 25 Jun 2007 17:49:27 +0000 |
| Subject: | #41779 [Opn->Fbk]: ftp_nlist() and ftp_rawlist() fail with open_basedir | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-114175@lists.php.net to get a copy of this message | ||
ID: 41779
Updated by: tony2001@php.net
Reported By: derernst at gmx dot ch
-Status: Open
+Status: Feedback
Bug Type: Safe Mode/open_basedir
Operating System: Linux
PHP Version: 5.2.3
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
Previous Comments:
------------------------------------------------------------------------
[2007-06-22 14:18:09] derernst at gmx dot ch
Description:
------------
After my ISP upgraded to PHP 5.2.3 (sorry I don't know from which
previous version), functions ftp_nlist() and ftp_rawlist() stopped
working:
PHP Warning: ftp_nlist() [function.ftp-nlist]: open_basedir restriction
in effect. File(/var/tmp/) is not within the allowed path(s):
(/data/htdocs/domain.com/:/usr/local/share/pear/:/tmp/:/var/tmp/) in
...
Note that the required path does actually match an allowed paths
entry:
- File(/var/tmp/)
- allowed path(s):
(/data/htdocs/domain.com/:/usr/local/share/pear/:/tmp/:/var/tmp/)
I found several bugs that might be related to this one, see bugs nr.
40141, 41518, 41684; bug 13720 describes the same phenomenon but
assumably for an other reason.
The functions work again after my ISP removed the trailing slashes from
the open_basedir entries. This can't be a desirable solution, though!
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=41779&edit=1