#41350 [Com]: Error in my_thread_global_end()
| From: | selarin at yandex dot ru | Date: | Sun, 01 Jul 2007 13:38:26 +0000 |
| Subject: | #41350 [Com]: Error in my_thread_global_end() | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-114507@lists.php.net to get a copy of this message | ||
ID: 41350
Comment by: selarin at yandex dot ru
Reported By: graham at directhostinguk dot com
Status: Feedback
Bug Type: MySQL related
Operating System: Windows 2003
PHP Version: 5.2.2
Assigned To: georg
New Comment:
This bug may break down some AJAX application. Response generated by
PHP-script influenced by this bug can not be parsed as XML because error
text is appended to it.
Previous Comments:
------------------------------------------------------------------------
[2007-07-01 02:34:06] anony at ousql dot cl
I work with php 5.2.3 and has the same problem.
i try changing the dll's from mysql and can see that my problem was
only the short syntaxys wasn't enabled.
i resolve editing php.ini
change
short_open_tag = Off to On
Regards
Antonia from Chile
------------------------------------------------------------------------
[2007-06-28 10:02:15] chris at crgs dot co dot uk
Scott is already aware of this, but I tried the snapshot from 12:30
27-06-2007 and it didn't fix the problem. However this might be because
the fix from the MySQL bug is necessary as well, and currently the PHP
snapshots contain libmysql.dll from PHP 5.0.37 rather than 5.0.45 (which
is apparently the one we need).
We may need to wait for MySQL to release their new version, and for the
new libmysql.dll to make its way across to PHP, before the bug will be
'properly' fixed.
------------------------------------------------------------------------
[2007-06-26 12:00:57] scottmac@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
I've committed a fix that should have resolved this.
------------------------------------------------------------------------
[2007-06-26 11:38:18] maxfm at abv dot bg
Just go to the end of php.ini
Change:
[PHP_MYSQL]
extension=php_mysql.dll
to:
;[PHP_MYSQL]
;extension=php_mysql.dll
Then go to:
;extension=php_mysql.dll
and enable it:
extension=php_mysql.dll
------------------------------------------------------------------------
[2007-06-24 09:37:28] ysangkok at gmail dot com
I'm experiencing the same problem with 5.2.3. Using CGI on IIS5.
I fixed it by using the dll from 5.2.1.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/41350
--
Edit this bug report at http://bugs.php.net/?id=41350&edit=1