#42099 [NEW]: wrong ownership detecttion => safe_mode error
| From: | bgs at bgs dot hu | Date: | Wed, 25 Jul 2007 10:42:47 +0000 |
| Subject: | #42099 [NEW]: wrong ownership detecttion => safe_mode error | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-115416@lists.php.net to get a copy of this message | ||
From: bgs at bgs dot hu
Operating system: Linux
PHP version: 5.2.3
PHP Bug Type: Filesystem function related
Bug description: wrong ownership detecttion => safe_mode error
Description:
------------
We occasionally but regularly get errors like this: Warning: realpath()
[function.realpath]: SAFE MODE Restriction in effect. The script whose
uid/gid is 99/99 is not allowed to access /path/to/dir owned by uid/gid 0/0
.....
The problem is that the directory in the error message is actually owned
by 99/99.
The bug looks similar to #18500, but that one looks like Solaris only.
Reproduce code:
---------------
Anything that uses realpath.
Expected result:
----------------
The script should run :)
safe_mode now stops it.
Actual result:
--------------
The above type of error message.
--
Edit bug report at http://bugs.php.net/?id=42099&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=42099&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=42099&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=42099&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=42099&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=42099&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=42099&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=42099&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=42099&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=42099&r=support
Expected behavior: http://bugs.php.net/fix.php?id=42099&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=42099&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=42099&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=42099&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=42099&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=42099&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=42099&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=42099&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=42099&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=42099&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=42099&r=mysqlcfg