#42099 [Opn->Fbk]: wrong ownership detecttion => safe_mode error
| From: | jani@php.net | Date: | Wed, 25 Jul 2007 14:34:13 +0000 |
| Subject: | #42099 [Opn->Fbk]: wrong ownership detecttion => safe_mode error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-115433@lists.php.net to get a copy of this message | ||
ID: 42099
Updated by: jani@php.net
Reported By: bgs at bgs dot hu
-Status: Open
+Status: Feedback
Bug Type: Filesystem function related
Operating System: Linux
PHP Version: 5.2.3
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
Previous Comments:
------------------------------------------------------------------------
[2007-07-25 10:42:47] bgs at bgs dot hu
Description:
------------
We occasionally but regularly get errors like this: Warning: realpath()
[function.realpath]: SAFE MODE Restriction in effect. The script whose
uid/gid is 99/99 is not allowed to access /path/to/dir owned by uid/gid
0/0 .....
The problem is that the directory in the error message is actually
owned by 99/99.
The bug looks similar to #18500, but that one looks like Solaris only.
Reproduce code:
---------------
Anything that uses realpath.
Expected result:
----------------
The script should run :)
safe_mode now stops it.
Actual result:
--------------
The above type of error message.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42099&edit=1