#42339 [NEW]: Can't Build a CLI *only* must have APXS enabled
From: codeslinger at compsalot dot com
Operating system: SimplyMEPIS Linux 6.5
PHP version: 5.2.3
PHP Bug Type: Compile Failure
Bug description: Can't Build a CLI *only* must have APXS enabled
Description:
------------
There are many options for PHP, such as ncurses, which are not compatible
with phpN-mod.so
But when trying to build a CLI only config, it fails with an error message
that APXS is not enabled.
Reproduce code:
---------------
I tried many variants, here is the simplest:
'./configure' --enable-cli --disable-cgi --without-apxs2
--without-apxs
Expected result:
----------------
Expected: No errors
Note: the following command *does* work
'./configure' --enable-cli --disable-cgi
'--with-apxs2=/usr/bin/apxs2'
Actual result:
--------------
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...
Sorry, I was not able to successfully run APXS. Possible reasons:
1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /usr/local/src/php-5.2.3/no follows
./configure: line 4396: /usr/local/src/php-5.2.3/no: No such file or
directory
configure: error: Aborting
--
Edit bug report at http://bugs.php.net/?id=42339&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=42339&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=42339&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=42339&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=42339&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=42339&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=42339&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=42339&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=42339&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=42339&r=support
Expected behavior: http://bugs.php.net/fix.php?id=42339&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=42339&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=42339&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=42339&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=42339&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=42339&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=42339&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=42339&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=42339&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=42339&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=42339&r=mysqlcfg
Thread (6 messages)
- codeslinger at compsalot dot com