#42339 [Opn->Fbk]: Can't Build a CLI *only* must have APXS enabled
| From: | jani@php.net | Date: | Thu, 23 Aug 2007 09:19:13 +0000 |
| Subject: | #42339 [Opn->Fbk]: Can't Build a CLI *only* must have APXS enabled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-116529@lists.php.net to get a copy of this message | ||
ID: 42339
Updated by: jani@php.net
Reported By: codeslinger at compsalot dot com
-Status: Open
+Status: Feedback
Bug Type: *General Issues
Operating System: SimplyMEPIS Linux 6.5
PHP Version: 5.2.3
New Comment:
# ./configure --disable-cgi
or
# ./configure --without-apxs2
Both work just fine here. You're simply doing something wrong or I'm
high on crack. :)
I even removed Apache from my test machine to be sure.
Any other SAPIs aren't enabled by default except for CLI and CGI.
With plain ./configure without any options you get both.
Please it with this latest snapshot instead of 5.2.3:
http://snaps.php.net/php5.2-latest.tar.gz
Previous Comments:
------------------------------------------------------------------------
[2007-08-22 19:13:53] codeslinger at compsalot dot com
The sources used are fine, I downloaded them direct from php.net and
verified the md5.
The documentation on the options is incomplete.
I tried --without-apxs because even though it is not documented, it is
symmetrical to the option --with-apxs which is documented, but that did
not work. Also, not saying anything about apxs at all did not work
either. Everything I tried, the ./configure failed.
After entering this bug and thinking about it some more, it occurred to
me to try --disable-apxs and did discover that it was the only thing
which produced the desired behavior of a CLI only build. And that's
when I changed the category to a documentation bug. Anything else
results in the error: "Sorry, I was not able to successfully run APXS."
I get that error even though I have not specified --with-apxs.
php by default is trying to build the apxs version even when it is not
requested.
I note in the change log that there have been some recent changes to
the "make". perhaps this problem is newly introduced.
Also my actual goal was to build both CGI and CLI at the same time, but
for the purpose of this bug I decided to simplify and isolate as much as
possible.
------------------------------------------------------------------------
[2007-08-20 07:48:19] jani@php.net
This is not true. Simply doing './configure --disable-cgi' gives you
CLI. There isn't such option as '--disable-apxs'..
You propably used unclean sources.
------------------------------------------------------------------------
[2007-08-18 17:46:21] codeslinger at compsalot dot com
this is actually a documentation problem.
the correct command should be
'./configure' --enable-cli --disable-cgi --disable-apxs
------------------------------------------------------------------------
[2007-08-18 17:36:23] codeslinger at compsalot dot com
Description:
------------
There are many options for PHP, such as ncurses, which are not
compatible with phpN-mod.so
But when trying to build a CLI only config, it fails with an error
message that APXS is not enabled.
Reproduce code:
---------------
I tried many variants, here is the simplest:
'./configure' --enable-cli --disable-cgi --without-apxs2
--without-apxs
Expected result:
----------------
Expected: No errors
Note: the following command *does* work
'./configure' --enable-cli --disable-cgi
'--with-apxs2=/usr/bin/apxs2'
Actual result:
--------------
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...
Sorry, I was not able to successfully run APXS. Possible reasons:
1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /usr/local/src/php-5.2.3/no follows
./configure: line 4396: /usr/local/src/php-5.2.3/no: No such file or
directory
configure: error: Aborting
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42339&edit=1