Bug #17905 Updated: Reference to Bug #17881
| From: | frodo at chatfree dot org | Date: | Fri, 21 Jun 2002 19:24:43 +0000 |
| Subject: | Bug #17905 Updated: Reference to Bug #17881 | ||
| References: | 1 | Groups: | php.bugs php.doc |
| Request: | Send a blank email to php-bugs+get-11730@lists.php.net to get a copy of this message | ||
ID: 17905
Updated by: frodo@chatfree.org
Reported By: frodo@chatfree.org
Status: Bogus
Bug Type: Documentation problem
Operating System: Freebsd
PHP Version: 4.2.1
New Comment:
I added the mod_pph4 and I did this:
1. Make clean in install apache and in the php
2. install the mod_php4
3. re-compiled and installed apache then php
Now when I try and start apache I am getting this error?
ptay1-ds# /www/bin/apachectl start
Syntax error on line 206 of /www/conf/httpd.conf:
Cannot load /home/www/libexec/libphp4.so into server:
/home/www/libexec/libphp4.so: Undefined symbol "apr_bucket_type_file"
/www/bin/apachectl start: httpd could not be started
ptay1-ds#
I like php, but I am getting fustrated with it now. Please help me.
Thank you
Previous Comments:
------------------------------------------------------------------------
[2002-06-21 14:34:48] rasmus@php.net
This is not a bug report - if you feel the need to gripe, do so on the
mailing lists like everyone else.
------------------------------------------------------------------------
[2002-06-21 13:20:45] cynic@php.net
hm, is this that hard (talking about FreeBSD)?
# (cd /usr/ports/www/mod_php4 && make install)
Please, be more specific in your description of the problem.
Also, as always, the documentation source is available, and patches are
welcome.
------------------------------------------------------------------------
[2002-06-21 12:56:40] frodo@chatfree.org
This is in reference to bug report# Bug #17881
The docs for php is poorley written and it lacks the proper
documentation to explain how to install php with apache on the majority
of the operating systems. Freebsd does not even come close to
slackware or redhat. There is also so many options with ./configure
that is used with apache and php that is the possible combinations are
more then 100 options.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17905&edit=1