Bug #17909: Undefined symbol "apr_bucket_type_file

From: Date: Fri, 21 Jun 2002 19:29:27 +0000
Subject: Bug #17909: Undefined symbol "apr_bucket_type_file
Groups: php.bugs php.doc 
Request: Send a blank email to php-bugs+get-11731@lists.php.net to get a copy of this message
From: frodo@chatfree.org Operating system: Freebsd PHP version: 4.2.1 PHP Bug Type: Documentation problem Bug description: Undefined symbol "apr_bucket_type_file hm, is this that hard (talking about FreeBSD)? # (cd /usr/ports/www/mod_php4 && make install) Please, be more specific in your description of the problem. Also, as always, the documentation source is available, and patches are welcome. [21 Jun 2:34pm] rasmus@php.net This is not a bug report - if you feel the need to gripe, do so on the mailing lists like everyone else. [21 Jun 3:24pm] frodo@chatfree.org I added the mod_pph4 and I did this: 1. Make clean in install apache and in the php 2. install the mod_php4 3. re-compiled and installed apache then php Now when I try and start apache I am getting this error? ptay1-ds# /www/bin/apachectl start Syntax error on line 206 of /www/conf/httpd.conf: Cannot load /home/www/libexec/libphp4.so into server: /home/www/libexec/libphp4.so: Undefined symbol "apr_bucket_type_file" /www/bin/apachectl start: httpd could not be started ptay1-ds# I like php, but I am getting fustrated with it now. Please help me. Thank you -- Edit bug report at http://bugs.php.net/?id=17909&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17909&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17909&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17909&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17909&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17909&r=support Expected behavior: http://bugs.php.net/fix.php?id=17909&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17909&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17909&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17909&r=globals

« previous php.bugs (#11731) next »