Bug #16901 Updated: ldap_bind no longer works
| From: | venaas@php.net | Date: | Fri, 21 Jun 2002 19:31:34 +0000 |
| Subject: | Bug #16901 Updated: ldap_bind no longer works | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11732@lists.php.net to get a copy of this message | ||
ID: 16901
Updated by: venaas@php.net
Reported By: macchi@in2p3.fr
Status: Open
Bug Type: LDAP related
Operating System: Solaris 8
PHP Version: 4.2.0
New Comment:
What LDAP library are you using? Might be some conflict
between the library you're using and LDAP stuff that
comes with Solaris 8. Perhaps PHP 4.2.0 isn't linked
with the same libraries or in the same order as 4.1.2.
You could also check what phpinfo() says about the lib
used.
Previous Comments:
------------------------------------------------------------------------
[2002-04-29 09:50:24] macchi@in2p3.fr
Ok : I tried again with Autoconf 2.13 but the issue
persists !
------------------------------------------------------------------------
[2002-04-29 09:07:55] mfischer@php.net
You have to to use autoconf >2.13< . It's all about that autoconf 2.52
with which the original ./configure script was built seems to be buggy
(or some bug in configure.in, whatever)
------------------------------------------------------------------------
[2002-04-29 09:03:57] macchi@in2p3.fr
I remove the configure script and rebuild it with builconf
:
buildconf: checking installation...
buildconf: autoconf version 2.52 (ok)
buildconf: automake version 1.5 (ok)
buildconf: libtool version 1.4.2 (ok)
rebuilding configure
rebuilding main/php_config.h.in
I rebuilt and reinstalled by I keep on getting the same
error.
------------------------------------------------------------------------
[2002-04-29 08:27:15] mfischer@php.net
And exactly the same script works with 4.1.2 ?
If so, this _may_ be related to an autoconf bug we had also with mysql
in the 4.2.0 release, though I'm not sure.
Can you try deleting the ./configure script in php-4.2.0 and rerun
./buildconf with autoconf 2.13 ?
------------------------------------------------------------------------
[2002-04-29 08:23:50] macchi@in2p3.fr
After have upgrade my PHP distribution from versin 4.1.2 to
version 4.2.0, the ldap_bind function no longer works :
My script is :
<?php
define("LDAP_HOSTNAME", "ldapserver.in2p3.fr");
define("LDAP_BASEDN", "o=in2p3, c=fr");
$cid = ldap_connect(LDAP_HOSTNAME);
ldap_bind($cid);
echo ldap_search($cid, LDAP_BASEDN, "(objectclass=*)");
?>
It perfacly works whith php 4.1.2.
With 4.2.0 I get the following error :
Warning: LDAP: Unable to bind to server: Can't contact LDAP
server in /sites/webtest/htdocs/ldap/test.php on line 13
(which is the line number of ldap_bind instruction).
Obviously I didn't change anything in the OpenLDAP release
I use nor in the compiler (Sun cc).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16901&edit=1