Bug #16901 Updated: ldap_bind no longer works
| From: | mfischer@php.net | Date: | Mon, 29 Apr 2002 12:27:15 +0000 |
| Subject: | Bug #16901 Updated: ldap_bind no longer works | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-6449@lists.php.net to get a copy of this message | ||
ID: 16901
Updated by: mfischer@php.net
Reported By: macchi@in2p3.fr
-Status: Open
+Status: Feedback
Bug Type: LDAP related
Operating System: Solaris 8
PHP Version: 4.2.0
New Comment:
And exactly the same script works with 4.1.2 ?
If so, this _may_ be related to an autoconf bug we had also with mysql
in the 4.2.0 release, though I'm not sure.
Can you try deleting the ./configure script in php-4.2.0 and rerun
./buildconf with autoconf 2.13 ?
Previous Comments:
------------------------------------------------------------------------
[2002-04-29 08:23:50] macchi@in2p3.fr
After have upgrade my PHP distribution from versin 4.1.2 to
version 4.2.0, the ldap_bind function no longer works :
My script is :
<?php
define("LDAP_HOSTNAME", "ldapserver.in2p3.fr");
define("LDAP_BASEDN", "o=in2p3, c=fr");
$cid = ldap_connect(LDAP_HOSTNAME);
ldap_bind($cid);
echo ldap_search($cid, LDAP_BASEDN, "(objectclass=*)");
?>
It perfacly works whith php 4.1.2.
With 4.2.0 I get the following error :
Warning: LDAP: Unable to bind to server: Can't contact LDAP
server in /sites/webtest/htdocs/ldap/test.php on line 13
(which is the line number of ldap_bind instruction).
Obviously I didn't change anything in the OpenLDAP release
I use nor in the compiler (Sun cc).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16901&edit=1