#42822 [NEW]: Unable to load dynamic library '../mysql.ini'
| From: | chriswhite31 at hotmail dot com | Date: | Tue, 02 Oct 2007 00:06:45 +0000 |
| Subject: | #42822 [NEW]: Unable to load dynamic library '../mysql.ini' | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-118040@lists.php.net to get a copy of this message | ||
From: chriswhite31 at hotmail dot com
Operating system: Redhat Linux Fedora 5
PHP version: 5.2.4
PHP Bug Type: Dynamic loading
Bug description: Unable to load dynamic library '../mysql.ini'
Description:
------------
Hey, i am trying to run a Scheduled Cron Job using "php --dump (link) >
/dev/null" and i am recieving this error;
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/mysql.ini' - /usr/lib/php/modules/mysql.ini: file too
short in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/php_mysql.dll' - /usr/lib/php/modules/php_mysql.dll:
invalid ELF header in Unknown on line 0
PHP Warning: Module 'mysql' already loaded in Unknown on line 0
Could not open input file:
http://www.theshadowofevil.com/crons/backupDB.php?StartBackup=normal
PHPInfo():http://www.theshadowofevil.com/phpinfo.php
PHP Version:5.1.6
System hostname:theshadowofevil.com
Operating system:Redhat Linux Fedora 5
Webmin version:1.370
Reproduce code:
---------------
Contents of mysql.ini
; Enable mysql extension module
extension=mysql.so
Contents of php_mysql.dll
MZ
Contents of mysql.so
ELF
Expected result:
----------------
Backup mysql database.
Another script should update mysql database.
Actual result:
--------------
Produces error from the command line.
--
Edit bug report at http://bugs.php.net/?id=42822&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=42822&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=42822&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=42822&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=42822&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=42822&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=42822&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=42822&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=42822&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=42822&r=support
Expected behavior: http://bugs.php.net/fix.php?id=42822&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=42822&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=42822&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=42822&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=42822&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=42822&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=42822&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=42822&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=42822&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=42822&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=42822&r=mysqlcfg