#42822 [Opn->Bgs]: Unable to load dynamic library '../mysql.ini'
| From: | tony2001@php.net | Date: | Tue, 02 Oct 2007 09:24:20 +0000 |
| Subject: | #42822 [Opn->Bgs]: Unable to load dynamic library '../mysql.ini' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-118050@lists.php.net to get a copy of this message | ||
ID: 42822
Updated by: tony2001@php.net
Reported By: chriswhite31 at hotmail dot com
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Redhat Linux Fedora 5
PHP Version: 5.2.4
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions. Due to the volume
of reports we can not explain in detail here why your report is not
a bug. The support channels will be able to provide an explanation
for you.
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2007-10-02 00:10:41] chriswhite31 at hotmail dot com
Ive made the directory unwriteable because i forgot to remove the
exposed link / database.
------------------------------------------------------------------------
[2007-10-02 00:06:45] chriswhite31 at hotmail dot com
Description:
------------
Hey, i am trying to run a Scheduled Cron Job using "php --dump (link) >
/dev/null" and i am recieving this error;
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/mysql.ini' - /usr/lib/php/modules/mysql.ini: file
too short in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/php_mysql.dll' -
/usr/lib/php/modules/php_mysql.dll: invalid ELF header in Unknown on
line 0
PHP Warning: Module 'mysql' already loaded in Unknown on line 0
Could not open input file:
http://www.theshadowofevil.com/crons/backupDB.php?StartBackup=normal
PHPInfo():http://www.theshadowofevil.com/phpinfo.php
PHP Version:5.1.6
System hostname:theshadowofevil.com
Operating system:Redhat Linux Fedora 5
Webmin version:1.370
Reproduce code:
---------------
Contents of mysql.ini
; Enable mysql extension module
extension=mysql.so
Contents of php_mysql.dll
MZ
Contents of mysql.so
ELF
Expected result:
----------------
Backup mysql database.
Another script should update mysql database.
Actual result:
--------------
Produces error from the command line.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42822&edit=1