ID: 44905
Comment by: mvx1nok at gmail dot com
Reported By: ionut dot stan at yahoo dot com
Status: Assigned
Bug Type: Dynamic loading
Operating System: Windows XP professional 64bit
PHP Version: 5.2.6
Assigned To: pajoye
New Comment:
I've the same problem with Windows XP Professional 32bit SP2, downgrade
to 5.2.5 could work too.
Previous Comments:
------------------------------------------------------------------------
[2008-05-04 20:13:36] pajoye@php.net
It is due to a little change in the client lib and we did not notice
that the extension got linked dynamically. You will be able to use the
version from the snaps soon (and profit from the client library version
8.3.1).
------------------------------------------------------------------------
[2008-05-03 16:09:40] ionut dot stan at yahoo dot com
Description:
------------
I have just downloaded PHP 5.2.6 and installed it from the zip
archive.
Enabling the following in php.ini caused a strange error:
Minimum modifications to php.ini for reproducing:
extension=php_pdo_pgsql.dll
extension=php_pgsql.dll
Error: a pop-up that says:
"php.exe Unable to load component. This application has failed to start
because LIBPQ.dll was not found. Re-installing the application may fix
the problem."
I then tried PHP 5.2.5, maybe was something with my OS. Aparently this
one works, with the same php.ini.
One more try was to replace the .dll-s in the 5.2.6 installation with
the ones in 5.2.5. This works too.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=44905&edit=1