#44905 [Com]: PHP 5.2.6 fails to load PostgreSQL related libraries
| From: | piotrprz at gmail dot com | Date: | Fri, 30 May 2008 10:24:17 +0000 |
| Subject: | #44905 [Com]: PHP 5.2.6 fails to load PostgreSQL related libraries | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-125371@lists.php.net to get a copy of this message | ||
ID: 44905
Comment by: piotrprz at gmail dot com
Reported By: ionut dot stan at yahoo dot com
Status: Assigned
Bug Type: Dynamic loading
Operating System: Windows XP professional 64bit
PHP Version: 5.2.6
Assigned To: pajoye
New Comment:
For those looking for a workaround:
1. download libpq.dll from
http://support.nusphere.com/viewtopic.php?t=4847
and copy it to your php
directory
2. copy libeay32.dll to libeay32-0.9.8e.dll
3. copy ssleay32.dll to ssleay32-0.9.8e.dll
I tested it for a while and seems to work fine.
Previous Comments:
------------------------------------------------------------------------
[2008-05-16 18:40:08] pajoye@php.net
"8.3.1 do not support VC6 anymore, while 8.2.7 does support it fine."
I got the same error with vc6 than the ones I got using 8.3.1. Linker
error and struct redefinitionfo addrinfo and sockaddr_storage.
If you succeeded to compile it using VC6 (or VC2k5:) please let us know
how.
------------------------------------------------------------------------
[2008-05-13 21:23:35] dnd at yandex dot ru
8.3.1 do not support VC6 anymore, while 8.2.7 does support it fine.
------------------------------------------------------------------------
[2008-05-06 13:59:48] pajoye@php.net
Little update:
Libpq and more generally postgresql 8.3.1 do not support VC6 anymore.
As we use it for PHP binaries, we will have to go back to 7.x for 5.2.x.
------------------------------------------------------------------------
[2008-05-06 13:44:43] mvx1nok at gmail dot com
I've the same problem with Windows XP Professional 32bit SP2, downgrade
to 5.2.5 could work too.
------------------------------------------------------------------------
[2008-05-04 20:13:36] pajoye@php.net
It is due to a little change in the client lib and we did not notice
that the extension got linked dynamically. You will be able to use the
version from the snaps soon (and profit from the client library version
8.3.1).
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/44905
--
Edit this bug report at http://bugs.php.net/?id=44905&edit=1