#44967 [NEW]: FastCGI broken in 5.2.6 NTS on IIS
| From: | randy at rcs-comp dot com | Date: | Sun, 11 May 2008 05:23:29 +0000 |
| Subject: | #44967 [NEW]: FastCGI broken in 5.2.6 NTS on IIS | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-124890@lists.php.net to get a copy of this message | ||
From: randy at rcs-comp dot com
Operating system: Windows 2003 Server
PHP version: 5.2.6
PHP Bug Type: CGI related
Bug description: FastCGI broken in 5.2.6 NTS on IIS
Description:
------------
I am using the technique described here:
http://learn.iis.net/page.aspx/247/using-fastcgi-to-host-php-applications-on-iis-60/
to get PHP running on IIS with fastcgi. I have confirmed that the
following three builds will run correctly on my Windows 2003 server setup
according to the instructions above:
- PHP 5.2.5 NTS
- PHP 5.2.5 TS
- PHP 5.2.6 TS
However, when trying to run with 5.2.6 NTS, as is recommended in the above
URL, I get an IIS error.
Reproduce code:
---------------
phpinfo();
Expected result:
----------------
normal phpinfo() output
Actual result:
--------------
-----------------------------------------------------
FastCGI Error
The FastCGI Handler was unable to process the request.
Error Details:
* Error Number: 5 (0x80070005).
* Error Description: Access is denied.
HTTP Error 500 - Server Error.
Internet Information Services (IIS)
-----------------------------------------------------
--
Edit bug report at http://bugs.php.net/?id=44967&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=44967&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=44967&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=44967&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=44967&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=44967&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=44967&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=44967&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=44967&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=44967&r=support
Expected behavior: http://bugs.php.net/fix.php?id=44967&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=44967&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=44967&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=44967&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=44967&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=44967&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=44967&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=44967&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=44967&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=44967&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=44967&r=mysqlcfg