#44967 [Com]: FastCGI broken in 5.2.6 NTS on IIS

From: Date: Mon, 16 Jun 2008 21:53:12 +0000
Subject: #44967 [Com]: FastCGI broken in 5.2.6 NTS on IIS
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-125815@lists.php.net to get a copy of this message
ID: 44967 Comment by: madams at ezrac dot com Reported By: randy at rcs-comp dot com Status: Open Bug Type: CGI related Operating System: Windows 2003 Server PHP Version: 5.2.6 New Comment: I added read access for "Everyone" to my PHP folder, and that seems to allow PHP to execute. Now I'm getting error number 1073741819, which according to http://forums.iis.net/t/1148416.aspx may be an extensions error. Using 5.2.6 on Win2003. Previous Comments: ------------------------------------------------------------------------ [2008-05-11 05:23:28] randy at rcs-comp dot com Description: ------------ I am using the technique described here: http://learn.iis.net/page.aspx/247/using-fastcgi-to-host-php-applications-on-iis-60/ to get PHP running on IIS with fastcgi. I have confirmed that the following three builds will run correctly on my Windows 2003 server setup according to the instructions above: - PHP 5.2.5 NTS - PHP 5.2.5 TS - PHP 5.2.6 TS However, when trying to run with 5.2.6 NTS, as is recommended in the above URL, I get an IIS error. Reproduce code: --------------- phpinfo(); Expected result: ---------------- normal phpinfo() output Actual result: -------------- ----------------------------------------------------- FastCGI Error The FastCGI Handler was unable to process the request. Error Details: * Error Number: 5 (0x80070005). * Error Description: Access is denied. HTTP Error 500 - Server Error. Internet Information Services (IIS) ----------------------------------------------------- ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=44967&edit=1

« previous php.bugs (#125815) next »