Bug #16413 Updated: Apache Startup Failure: Undefined symbol "_mail_string"

From: Date: Sat, 29 Jun 2002 05:00:07 +0000
Subject: Bug #16413 Updated: Apache Startup Failure: Undefined symbol "_mail_string"
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-12498@lists.php.net to get a copy of this message
ID: 16413 Updated by: php-bugs@lists.php.net Reported By: markscarbrough@hotmail.com -Status: Feedback +Status: No Feedback Bug Type: IMAP related Operating System: OpenBSD 3.0 PHP Version: 4.1.2 New Comment: No feedback was provided for this bug for over a month, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-06-11 04:56:13] karl.soulabaille@free.fr Latest ports for OpenBSD 3.0 works now for me. Don't ask me why :-) ------------------------------------------------------------------------ [2002-06-01 16:18:10] karl.soulabaille@free.fr I have the same problem when compiling my own port in the same way but using PHP 4.1.2. Precompiled packages work also fine for me. (And may you see my bug report 17165 which appear to be near problem (ie. libc-client.a)). ------------------------------------------------------------------------ [2002-05-28 13:06:21] derick@php.net Is this still an issue with PHP 4.2.1? ------------------------------------------------------------------------ [2002-04-03 21:27:02] markscarbrough@hotmail.com I was using the following i386 port: php4-4.0.6p1-gettext-imap-mhash-no_x11-mcrypt-mysql.tgz It worked fine with the apache bundled with OpenBSD. I used pkg_delete to remove the php port (so as not to cause any conflicts when I compiled my own php in /usr/local). I also compiled and installed my own copy of apache/mod_ssl without a hitch under /home/httpd before installing PHP. As long as I do not compile PHP with imap support it works fine (that is what I have running now). I originally tried to compile php against the c-client port that is bundled with OpenBSD, but I was unable to complete a configure against this version of c-client. The configure script asked me to add the --with-kerberos flag to the configure string. When I do add this flag, configure gives me an error "Attention--something is likely to be wrong, configure was unable to determine a basic system feature..." (paraphrased). After trying a few times with different DIR options to the --with-kerberos flag(/usr/local, /usr, absent DIR option) I used pkg_delete to remove the c-client port and downloaded and compiled my own in a futile attempt to make things work! With my own compilation of c-client the configure script works fine but I am (as you know) unable to start apache. If it helps, this is a brand new setup, running OpenBSD 3.0, i386, with only ports from the 3.0 release tree. No old packages, not an upgrade, etc. Gosh, thanks for looking into this--hope any this info helps your development efforts! ------------------------------------------------------------------------ [2002-04-03 20:20:14] sniper@php.net And does the PHP4 from the openBSD ports work for you? --Jani ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/16413 -- Edit this bug report at http://bugs.php.net/?id=16413&edit=1

« previous php.bugs (#12498) next »