Bug #16413 Updated: Apache Startup Failure: Undefined symbol "_mail_string"

From: Date: Sat, 01 Jun 2002 20:18:10 +0000
Subject: Bug #16413 Updated: Apache Startup Failure: Undefined symbol "_mail_string"
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-9114@lists.php.net to get a copy of this message
ID: 16413 Updated by: karl.soulabaille@free.fr Reported By: markscarbrough@hotmail.com Status: Feedback Bug Type: IMAP related Operating System: OpenBSD 3.0 PHP Version: 4.1.2 New Comment: I have the same problem when compiling my own port in the same way but using PHP 4.1.2. Precompiled packages work also fine for me. (And may you see my bug report 17165 which appear to be near problem (ie. libc-client.a)). Previous Comments: ------------------------------------------------------------------------ [2002-05-28 13:06:21] derick@php.net Is this still an issue with PHP 4.2.1? ------------------------------------------------------------------------ [2002-04-03 21:27:02] markscarbrough@hotmail.com I was using the following i386 port: php4-4.0.6p1-gettext-imap-mhash-no_x11-mcrypt-mysql.tgz It worked fine with the apache bundled with OpenBSD. I used pkg_delete to remove the php port (so as not to cause any conflicts when I compiled my own php in /usr/local). I also compiled and installed my own copy of apache/mod_ssl without a hitch under /home/httpd before installing PHP. As long as I do not compile PHP with imap support it works fine (that is what I have running now). I originally tried to compile php against the c-client port that is bundled with OpenBSD, but I was unable to complete a configure against this version of c-client. The configure script asked me to add the --with-kerberos flag to the configure string. When I do add this flag, configure gives me an error "Attention--something is likely to be wrong, configure was unable to determine a basic system feature..." (paraphrased). After trying a few times with different DIR options to the --with-kerberos flag(/usr/local, /usr, absent DIR option) I used pkg_delete to remove the c-client port and downloaded and compiled my own in a futile attempt to make things work! With my own compilation of c-client the configure script works fine but I am (as you know) unable to start apache. If it helps, this is a brand new setup, running OpenBSD 3.0, i386, with only ports from the 3.0 release tree. No old packages, not an upgrade, etc. Gosh, thanks for looking into this--hope any this info helps your development efforts! ------------------------------------------------------------------------ [2002-04-03 20:20:14] sniper@php.net And does the PHP4 from the openBSD ports work for you? --Jani ------------------------------------------------------------------------ [2002-04-03 19:15:38] markscarbrough@hotmail.com Diagnostic commands and their results (cut and pasted right from my ssh terminal): psi # nm /usr/local/lib/libc-client.a |grep mail_string 0000ca78 D _mail_string 00000470 t _mail_string_init 000004a0 t _mail_string_next 000004b4 t _mail_string_setpos U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string U _mail_string psi # find / -name libc-client.* /usr/local/lib/libc-client.a /usr/local/src/imap-2001a/c-client/libc-client.a ------------------------------------------------------------------------ [2002-04-03 18:55:00] sniper@php.net What does this command show: # nm /usr/local/lib/libc-client.a |grep mail_string And what about: # find / -name libc-client.* ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/16413 -- Edit this bug report at http://bugs.php.net/?id=16413&edit=1

« previous php.bugs (#9114) next »