#45121 [NEW]: PHP Startup: Unable to load dynamic library 'c:/root/php/ext/php_openssl.dll'
| From: | chameleon_red_one at o2 dot pl | Date: | Wed, 28 May 2008 21:37:07 +0000 |
| Subject: | #45121 [NEW]: PHP Startup: Unable to load dynamic library 'c:/root/php/ext/php_openssl.dll' | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-125330@lists.php.net to get a copy of this message | ||
From: chameleon_red_one at o2 dot pl
Operating system: Windows XP
PHP version: 5.2.6
PHP Bug Type: IIS related
Bug description: PHP Startup: Unable to load dynamic library
'c:/root/php/ext/php_openssl.dll'
Description:
------------
I have such problem that if I am running PHP over Windows XP IIS 5.1 it is
not able to load libeay32.dll and ssleay32.dll from c:/root/php/
directory.
It results that I have no ssl (dump from phpinfo()):
Registered Stream Socket Transports tcp, udp
In php_error.log is something like that:
PHP Warning: PHP Startup: Unable to load dynamic library
'c:/root/php/ext/php_openssl.dll' - The operating system cannot run %1.
Strange is that if order IIS to execute php-cgi.exe from same path it
results:
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
So currently half of iis use php5isapi.dll and half php-cgi.exe.
Why such problem occurs is it bug or not - I was done about 100 of
searches and it is not help to find solution? I am very experience
programmer so I bet that it read in isapi mode ssleay32.dll from c:\windows
not c:\root\php but why cgi works?
Expected result:
----------------
I want to run *.php via php5isapi.dll on whole IIS 5.1 and not user
php-cgi.exe to have ssl protocol enable.
On phpinfo() I will be seeing:
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Actual result:
--------------
Currently isapi not allow to load php_openssl.dll extenstion on iis 5.1
Registered Stream Socket Transports tcp, udp
--
Edit bug report at http://bugs.php.net/?id=45121&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=45121&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=45121&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=45121&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=45121&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=45121&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=45121&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=45121&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=45121&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=45121&r=support
Expected behavior: http://bugs.php.net/fix.php?id=45121&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=45121&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=45121&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=45121&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=45121&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=45121&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=45121&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=45121&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=45121&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=45121&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=45121&r=mysqlcfg