#45121 [Bgs]: PHP Startup: Unable to load dynamic library 'c:/root/php/ext/php_openssl.dll'
| From: | chameleon_red_one at o2 dot pl | Date: | Tue, 22 Jul 2008 08:56:05 +0000 |
| Subject: | #45121 [Bgs]: PHP Startup: Unable to load dynamic library 'c:/root/php/ext/php_openssl.dll' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-127116@lists.php.net to get a copy of this message | ||
ID: 45121
User updated by: chameleon_red_one at o2 dot pl
Reported By: chameleon_red_one at o2 dot pl
Status: Bogus
Bug Type: IIS related
Operating System: Windows XP
PHP Version: 5.2.6
New Comment:
As I was observed is it is not what is suspected "It certainly fails to
load the ssl DLLs."
When I use php-cgi.exe as *.php server it always work.
When I use php5isapi.dll as *.php server it always not work.
In both case I use exactly the same php.ini on the same computer :)
So if it such simple why in the first case it works and in the second
case not works - I am not understand from your description and spend a
lot of time and not found it explained yet?
Previous Comments:
------------------------------------------------------------------------
[2008-07-21 12:25:42] pajoye@php.net
it works but the extension is not loaded. It certainly fails to load
the ssl DLLs. I close it (bogus), please reopen it if you consider that
there is other problems involved.
------------------------------------------------------------------------
[2008-05-28 21:37:07] chameleon_red_one at o2 dot pl
Description:
------------
I have such problem that if I am running PHP over Windows XP IIS 5.1 it
is not able to load libeay32.dll and ssleay32.dll from c:/root/php/
directory.
It results that I have no ssl (dump from phpinfo()):
Registered Stream Socket Transports tcp, udp
In php_error.log is something like that:
PHP Warning: PHP Startup: Unable to load dynamic library
'c:/root/php/ext/php_openssl.dll' - The operating system cannot run %1.
Strange is that if order IIS to execute php-cgi.exe from same path it
results:
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
So currently half of iis use php5isapi.dll and half php-cgi.exe.
Why such problem occurs is it bug or not - I was done about 100 of
searches and it is not help to find solution? I am very experience
programmer so I bet that it read in isapi mode ssleay32.dll from
c:\windows not c:\root\php but why cgi works?
Expected result:
----------------
I want to run *.php via php5isapi.dll on whole IIS 5.1 and not user
php-cgi.exe to have ssl protocol enable.
On phpinfo() I will be seeing:
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Actual result:
--------------
Currently isapi not allow to load php_openssl.dll extenstion on iis
5.1
Registered Stream Socket Transports tcp, udp
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45121&edit=1