#45418 [NEW]: configure script fails with --with-ldap enabled
| From: | mccullj at email dot uah dot edu | Date: | Wed, 02 Jul 2008 15:03:07 +0000 |
| Subject: | #45418 [NEW]: configure script fails with --with-ldap enabled | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-126208@lists.php.net to get a copy of this message | ||
From: mccullj at email dot uah dot edu
Operating system: Solaris 10
PHP version: 4.4.8
PHP Bug Type: LDAP related
Bug description: configure script fails with --with-ldap enabled
Description:
------------
The following configure script works:
./configure --prefix=/usr/local/php4.4.8
--with-config-file-path=/usr/local/h
p4.4.8 --with-apxs2=/usr/local/apache-test/bin/apxs --with-gettext
--with-mcrypt
--with-iconv=/usr/local --enable-mbstring=all --enable-mbregex --with-gd
--with
-png-dir=/usr/local --with-jpeg-dir=/usr/local
--with-mysql=/usr/local/mysql --w
ith-imap=/usr/local/imap2007b/ --with-openssl=/usr/local/ssl
--with-libxml-dir=/
usr/local --with-zlib=/usr/local --with-dom
but when I add --with-ldap to the end it fails. Here are the last two
lines of config.log:
configure:48597: checking for Java support
configure:49434: checking for LDAP support
The output of the configure command is:
checking for LDAP support... yes
configure: error: Cannot find ldap libraries in /usr/lib.
In the configure script, where that message is located (line 51702), it
appears to be looking for an Oracle LDAP library libclntsh rather than
Solaris LDAP libraries.
--
Edit bug report at http://bugs.php.net/?id=45418&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=45418&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=45418&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=45418&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=45418&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=45418&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=45418&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=45418&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=45418&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=45418&r=support
Expected behavior: http://bugs.php.net/fix.php?id=45418&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=45418&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=45418&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=45418&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=45418&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=45418&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=45418&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=45418&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=45418&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=45418&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=45418&r=mysqlcfg