#45418 [Opn->WFx]: configure script fails with --with-ldap enabled
| From: | jani@php.net | Date: | Fri, 11 Jul 2008 21:46:43 +0000 |
| Subject: | #45418 [Opn->WFx]: configure script fails with --with-ldap enabled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-126559@lists.php.net to get a copy of this message | ||
ID: 45418
Updated by: jani@php.net
Reported By: mccullj at email dot uah dot edu
-Status: Open
+Status: Wont fix
Bug Type: LDAP related
Operating System: Solaris 10
PHP Version: 4.4.8
New Comment:
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.
Previous Comments:
------------------------------------------------------------------------
[2008-07-02 15:03:07] mccullj at email dot uah dot edu
Description:
------------
The following configure script works:
./configure --prefix=/usr/local/php4.4.8
--with-config-file-path=/usr/local/h
p4.4.8 --with-apxs2=/usr/local/apache-test/bin/apxs --with-gettext
--with-mcrypt
--with-iconv=/usr/local --enable-mbstring=all --enable-mbregex
--with-gd --with
-png-dir=/usr/local --with-jpeg-dir=/usr/local
--with-mysql=/usr/local/mysql --w
ith-imap=/usr/local/imap2007b/ --with-openssl=/usr/local/ssl
--with-libxml-dir=/
usr/local --with-zlib=/usr/local --with-dom
but when I add --with-ldap to the end it fails. Here are the last two
lines of config.log:
configure:48597: checking for Java support
configure:49434: checking for LDAP support
The output of the configure command is:
checking for LDAP support... yes
configure: error: Cannot find ldap libraries in /usr/lib.
In the configure script, where that message is located (line 51702), it
appears to be looking for an Oracle LDAP library libclntsh rather than
Solaris LDAP libraries.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45418&edit=1