#45561 [NEW]: PHP-5.2.6 + Mod_FastCGI-2.4.6 + Suexec Apache 2.2.9 causes hangs/error 500
From: jamesslee at hotmail dot com
Operating system: centos-5
PHP version: 5.2.6
PHP Bug Type: Apache2 related
Bug description: PHP-5.2.6 + Mod_FastCGI-2.4.6 + Suexec Apache 2.2.9 causes hangs/error 500
Description:
------------
PHP5 compiled with:
./configure --prefix=/usr/local/php5 --enable-fastcgi
--enable-force-cgi-redirect
Basically, I am using Apache2 Suexec with mod_fastcgi using PHP 5.2.6 as a
cli. I am using the same apache directives and same fcgi script (the only
difference is that one points to the php4 binary vs php5 vinary). This
setup works with PHP-4.4.8, but not with PHP-5.2.6.
When I try to view test.php5 via the web browser, it just hangs until I
get the 500 error.
Reproduce code:
---------------
test.php5:
<? phpinfo(); ?>
Expected result:
----------------
I expect to see the results of the phpinfo function.
Actual result:
--------------
test.php5 hangs in the browser. The following logs are produced:
access.log:
X.X.X.X - - [19/Jul/2008:00:17:27 -0400] "GET /test.php5 HTTP/1.1" 500
545
error.log:
[Sat Jul 19 00:17:32 2008] [warn] FastCGI: (dynamic) server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" restarted (pid 3048)
[Sat Jul 19 00:17:32 2008] [warn] FastCGI: (dynamic) server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" (pid 3048) terminated by
calling exit with status '0'
[Sat Jul 19 00:17:35 2008] [error] [client X.X.X.X] (104)Connection reset
by peer: FastCGI: comm with server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" aborted: read failed
[Sat Jul 19 00:17:35 2008] [error] [client X.X.X.X] FastCGI: incomplete
headers (0 bytes) received from server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi"
--
Edit bug report at http://bugs.php.net/?id=45561&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=45561&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=45561&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=45561&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=45561&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=45561&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=45561&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=45561&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=45561&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=45561&r=support
Expected behavior: http://bugs.php.net/fix.php?id=45561&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=45561&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=45561&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=45561&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=45561&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=45561&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=45561&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=45561&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=45561&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=45561&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=45561&r=mysqlcfg
Thread (6 messages)
- jamesslee at hotmail dot com