#45561 [Opn->Fbk]: PHP-5.2.6 + Mod_FastCGI-2.4.6 + Suexec Apache 2.2.9 causes hangs/error 500
ID: 45561
Updated by: jani@php.net
Reported By: jamesslee at hotmail dot com
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: centos-5
PHP Version: 5.2.6
New Comment:
You're propably using the php.ini from that php4 installation?
I'd first nuke that and create totally new using the php.ini-dist or
preferrably php.ini-recommended file from the PHP 5.2.6 sources as base.
Previous Comments:
------------------------------------------------------------------------
[2008-07-19 04:27:25] jamesslee at hotmail dot com
Description:
------------
PHP5 compiled with:
./configure --prefix=/usr/local/php5 --enable-fastcgi
--enable-force-cgi-redirect
Basically, I am using Apache2 Suexec with mod_fastcgi using PHP 5.2.6
as a cli. I am using the same apache directives and same fcgi script
(the only difference is that one points to the php4 binary vs php5
vinary). This setup works with PHP-4.4.8, but not with PHP-5.2.6.
When I try to view test.php5 via the web browser, it just hangs until I
get the 500 error.
Reproduce code:
---------------
test.php5:
<? phpinfo(); ?>
Expected result:
----------------
I expect to see the results of the phpinfo function.
Actual result:
--------------
test.php5 hangs in the browser. The following logs are produced:
access.log:
X.X.X.X - - [19/Jul/2008:00:17:27 -0400] "GET /test.php5 HTTP/1.1" 500
545
error.log:
[Sat Jul 19 00:17:32 2008] [warn] FastCGI: (dynamic) server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" restarted (pid 3048)
[Sat Jul 19 00:17:32 2008] [warn] FastCGI: (dynamic) server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" (pid 3048) terminated by
calling exit with status '0'
[Sat Jul 19 00:17:35 2008] [error] [client X.X.X.X] (104)Connection
reset by peer: FastCGI: comm with server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi" aborted: read failed
[Sat Jul 19 00:17:35 2008] [error] [client X.X.X.X] FastCGI: incomplete
headers (0 bytes) received from server
"/home/foo/domains/foo.com/cgi-bin/php5.fcgi"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45561&edit=1
Thread (6 messages)