#45586 [Opn]: php_mbstring must be loaded before php_exif extension in php.ini
ID: 45586
Updated by: jani@php.net
-Summary: php_exif and php_mbstring crashing php
Reported By: bouke at haarsma dot eu
Status: Open
-Bug Type: *Configuration Issues
+Bug Type: Feature/Change Request
Operating System: Windows XP
PHP Version: 5.2.6
New Comment:
Better summary. There's no crash here.
Previous Comments:
------------------------------------------------------------------------
[2008-07-21 17:17:19] bouke at haarsma dot eu
Description:
------------
Please see: http://bugs.php.net/bug.php?id=27248
Also see: http://bugs.php.net/bug.php?id=32552
Using the latest php.ini files, the problem still exists. The default
order for loading the extensions is wrong and error-prone. The
'solution' as stated in the comments should also be reflected in the
php.ini-file.
Please note that this has been "solved" in 2005, but the bug is
introduced again.
Reproduce code:
---------------
Enter this into php.ini:
extension=php_exif.dll
extension=php_mbstring.dll
Solution:
extension=php_mbstring.dll
extension=php_exif.dll
(Swaped order)
Expected result:
----------------
-no error message-
Actual result:
--------------
-error message: "php_mbstring.dll" not found
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45586&edit=1
Thread (7 messages)