#45586 [Com]: php_mbstring must be loaded before php_exif extension in php.ini

From: Date: Wed, 23 Jul 2008 09:54:33 +0000
Subject: #45586 [Com]: php_mbstring must be loaded before php_exif extension in php.ini
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-127172@lists.php.net to get a copy of this message
 ID:               45586
 Comment by:       missingno at ifrance dot com
 Reported By:      bouke at haarsma dot eu
 Status:           Open
 Bug Type:         Feature/Change Request
 Operating System: Windows XP
 PHP Version:      5.2.6
 New Comment:

I guess the problem comes from the fact that the extension entries are
sorted by alphabetical order in the php.ini file.


Correcting the order of extensions would solve the problem but would
require a lot of testing because I think this problem also occurs with
other extensions as well...
I don't think it is such a good idea because the way the list is
currently written makes it easy to find the extensions you want to
activate. Also, each extension's page in the manual clearly has some
sort of a FAQ regarding installation/configuration.
The only problem I seen then is users that do not read the manual, but
I digress...

Anyway, I think this is a WONTFIX for now. One possible solution would
be for extensions to manage dependancies at runtime and let the user
know the steps to follow in order for the extension to work.
But this would probably put to much of a burden on the developpers
compared to the actual gain.


Previous Comments:
------------------------------------------------------------------------

[2008-07-21 17:30:45] jani@php.net

Better summary. There's no crash here.

------------------------------------------------------------------------

[2008-07-21 17:17:19] bouke at haarsma dot eu

Description:
------------
Please see: http://bugs.php.net/bug.php?id=27248
Also see: http://bugs.php.net/bug.php?id=32552

Using the latest php.ini files, the problem still exists. The default
order for loading the extensions is wrong and error-prone. The
'solution' as stated in the comments should also be reflected in the
php.ini-file.

Please note that this has been "solved" in 2005, but the bug is
introduced again.

Reproduce code:
---------------
Enter this into php.ini:

extension=php_exif.dll
extension=php_mbstring.dll

Solution:
extension=php_mbstring.dll
extension=php_exif.dll

(Swaped order)

Expected result:
----------------
-no error message-

Actual result:
--------------
-error message: "php_mbstring.dll" not found


------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=45586&edit=1



Thread (7 messages)

« previous php.bugs (#127172) next »