#45994 [Opn->Bgs]: "\" directive in php.ini, DISABLES ALL non-built-in php extensions
| From: | tularis@php.net | Date: | Thu, 04 Sep 2008 14:28:04 +0000 |
| Subject: | #45994 [Opn->Bgs]: "\" directive in php.ini, DISABLES ALL non-built-in php extensions | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-128676@lists.php.net to get a copy of this message | ||
ID: 45994
Updated by: tularis@php.net
Reported By: ipseno at yahoo dot com
-Status: Open
+Status: Bogus
Bug Type: *Configuration Issues
Operating System: Windows XP SP3
PHP Version: 5.3.0alpha2
New Comment:
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
You're escaping your ending quote (\" is an escape sequence for a
double-quote character).
Compare the same to a php-script which does
<?php
$foo = "bar\";
[...]
What would you expect here? A parse error.
What happens when you do the same in php.ini? it breaks
Seems pretty obvious to me ?
Previous Comments:
------------------------------------------------------------------------
[2008-09-04 14:20:26] ipseno at yahoo dot com
Actually...
"\" at the END of ANY directive in php.ini breaks configuration under
WinXP
Ie:
error_log = "E:\php-5.3.0alpha2\error.log\"
variables_order = "GPCS\"
------------------------------------------------------------------------
[2008-09-04 13:54:00] ipseno at yahoo dot com
Description:
------------
upload_tmp_dir directive in php.ini, DISABLES ALL non-built-in php
extensions
To recreate this:
In php.ini set:
upload_tmp_dir = "E:\"
create .php file
<?php
phpinfo();
?>
Under windows xp sp3 Apache/2.2.9b, parse it by php-cgi.exe
Now skip to upload_tmp_dir section, of generated page and look at a
HUGE part of php.ini copied in that filed!
That is..., everything from line upload_tmp_dir = "E:\", till the end
of php.ini
Commenting it out in php.ini.
;upload_tmp_dir = "E:\"
OR shifting slash!!!
upload_tmp_dir = "E:/"
...fixes it and enables all extensions again!
Actual result:
--------------
This is VERY POSSIBLE SOLUTION to:
Bug #13290 extension_dir directive is not working
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45994&edit=1