ID: 45994
User updated by: ipseno at yahoo dot com
Reported By: ipseno at yahoo dot com
Status: Bogus
Bug Type: *Configuration Issues
Operating System: Windows XP SP3
PHP Version: 5.3.0alpha2
New Comment:
Yes, I've found it out too.
It escapes string in php.ini.
Just 've been too tired I guess...
Previous Comments:
------------------------------------------------------------------------
[2008-09-04 14:28:13] pajoye@php.net
> Actually... "\" at the END of ANY directive in php.ini > breaks configuration under WinXP
What do you not understand behind escape sequence? it IS an escape
sequence and means that you escape the double quotes and do not close
the string.
There is no bug and please choose another channel to get support,
thanks for your understanding.
------------------------------------------------------------------------
[2008-09-04 14:28:04] tularis@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
You're escaping your ending quote (\" is an escape sequence for a
double-quote character).
Compare the same to a php-script which does
<?php
$foo = "bar\";
[...]
What would you expect here? A parse error.
What happens when you do the same in php.ini? it breaks
Seems pretty obvious to me ?
------------------------------------------------------------------------
[2008-09-04 14:20:26] ipseno at yahoo dot com
Actually...
"\" at the END of ANY directive in php.ini breaks configuration under
WinXP
Ie:
error_log = "E:\php-5.3.0alpha2\error.log\"
variables_order = "GPCS\"
------------------------------------------------------------------------
[2008-09-04 13:54:00] ipseno at yahoo dot com
Description:
------------
upload_tmp_dir directive in php.ini, DISABLES ALL non-built-in php
extensions
To recreate this:
In php.ini set:
upload_tmp_dir = "E:\"
create .php file
<?php
phpinfo();
?>
Under windows xp sp3 Apache/2.2.9b, parse it by php-cgi.exe
Now skip to upload_tmp_dir section, of generated page and look at a
HUGE part of php.ini copied in that filed!
That is..., everything from line upload_tmp_dir = "E:\", till the end
of php.ini
Commenting it out in php.ini.
;upload_tmp_dir = "E:\"
OR shifting slash!!!
upload_tmp_dir = "E:/"
...fixes it and enables all extensions again!
Actual result:
--------------
This is VERY POSSIBLE SOLUTION to:
Bug #13290 extension_dir directive is not working
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45994&edit=1