#42478 [Com]: php_mbstring.dll before php_exif.dll problem back again!
| From: | ro_nin_inside at hotmail dot com | Date: | Mon, 20 Oct 2008 02:32:05 +0000 |
| Subject: | #42478 [Com]: php_mbstring.dll before php_exif.dll problem back again! | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-129856@lists.php.net to get a copy of this message | ||
ID: 42478
Comment by: ro_nin_inside at hotmail dot com
Reported By: andy at haveland dot com
Status: Open
Bug Type: Feature/Change Request
Operating System: Windows x64
PHP Version: 5.2.3
New Comment:
i want this file
i am thanks
Previous Comments:
------------------------------------------------------------------------
[2007-08-30 02:45:12] andy at haveland dot com
Description:
------------
When upgrading from the php-5.2.3-Win32.zip and after checking and
migrating php.ini from php.ini-dist.txt this error reappears:
PHP Startup: Unable to load dynamic library './ext\php_exif.dll' - The
specified module could not be found.
The solution (hack) is to put php_mbstring.dll before php_exif.dll, and
make sure that this is the case (perhaps with a mention) in php.ini-dist
and php.ini-recommended and NOT to just sort the list of extensions
without due regard to dependencies!
The error message is also very confusing - all other modules loaded
successfully from the ext dir implying that php_exif.dll can't be found
even when it is also in the same dir.
The init routine should ideally collect all the enabled modules, check
dependencies and then report an error if not satisfied, and actually
mention which is the *real* module that couldn't be found.
Also, in the ini files, extension_dir = "./ext" should be default, to
match the path in the distribution package.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42478&edit=1