Req #42478 [Opn]: php_mbstring.dll before php_exif.dll problem back again!
| From: | cmb@php.net | Date: | Tue, 09 Jun 2015 16:15:53 +0000 |
| Subject: | Req #42478 [Opn]: php_mbstring.dll before php_exif.dll problem back again! | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-193253@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=42478&edit=1
ID: 42478
Updated by: cmb@php.net
Reported by: andy at haveland dot com
Summary: php_mbstring.dll before php_exif.dll problem back
again!
Status: Open
Type: Feature/Change Request
-Package: Windows Installer
+Package: *Configuration Issues
Operating System: Windows x64
PHP Version: 5.2.3
Block user comment: N
Private report: N
New Comment:
> The solution (hack) is to put php_mbstring.dll before
> php_exif.dll, and make sure that this is the case (perhaps with
> a mention) in php.ini-dist and php.ini-recommended and NOT to
> just sort the list of extensions without due regard to
> dependencies!
This is done so in recent PHP distributions.
Previous Comments:
------------------------------------------------------------------------
[2007-08-30 02:45:12] andy at haveland dot com
Description:
------------
When upgrading from the php-5.2.3-Win32.zip and after checking and migrating php.ini from
php.ini-dist.txt this error reappears:
PHP Startup: Unable to load dynamic library './ext\php_exif.dll' - The specified module
could not be found.
The solution (hack) is to put php_mbstring.dll before php_exif.dll, and make sure that this is the
case (perhaps with a mention) in php.ini-dist and php.ini-recommended and NOT to just sort the list
of extensions without due regard to dependencies!
The error message is also very confusing - all other modules loaded successfully from the ext dir
implying that php_exif.dll can't be found even when it is also in the same dir.
The init routine should ideally collect all the enabled modules, check dependencies and then report
an error if not satisfied, and actually mention which is the *real* module that couldn't be
found.
Also, in the ini files, extension_dir = "./ext" should be default, to match the path in
the distribution package.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=42478&edit=1