#47012 [NEW]: can't load libphp4.so
| From: | bulbapeppe at yahoo dot it | Date: | Mon, 05 Jan 2009 16:48:16 +0000 |
| Subject: | #47012 [NEW]: can't load libphp4.so | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-132565@lists.php.net to get a copy of this message | ||
From: bulbapeppe at yahoo dot it
Operating system: solaris 10
PHP version: 5.2.8
PHP Bug Type: Apache related
Bug description: can't load libphp4.so
Description:
------------
I have to start apache, but the command
LoadModule php4_module
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so
gives me the following problem:
Syntax error on line 28 of
/sunrm20/dati/edudbmgr/EDUDB/apache/conf/httpd.conf:
Cannot load
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so into
server: ld.so.1: httpd: fatal: relocation error: file
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so: symbol
ap_group_id: referenced symbol not found
./apachectl start: httpd could not be started
I would like to know two things:
1- shall I have a php installed ?
2- I've checked the bugs #14147, #6667 and #4179 but they aren't so
clear.
What shall I do?
Thanks,
bulbapeppe
Expected result:
----------------
no errors
Actual result:
--------------
Syntax error on line 28 of
/sunrm20/dati/edudbmgr/EDUDB/apache/conf/httpd.conf:
Cannot load
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so into
server: ld.so.1: httpd: fatal: relocation error: file
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so: symbol
ap_group_id: referenced symbol not found
./apachectl start: httpd could not be started
--
Edit bug report at http://bugs.php.net/?id=47012&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=47012&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=47012&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=47012&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=47012&r=fixedcvs
Fixed in CVS and need be documented: http://bugs.php.net/fix.php?id=47012&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=47012&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=47012&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=47012&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=47012&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=47012&r=support
Expected behavior: http://bugs.php.net/fix.php?id=47012&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=47012&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=47012&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=47012&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=47012&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=47012&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=47012&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=47012&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=47012&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=47012&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=47012&r=mysqlcfg