#47012 [Opn->WFx]: can't load libphp4.so
| From: | derick@php.net | Date: | Mon, 05 Jan 2009 17:02:15 +0000 |
| Subject: | #47012 [Opn->WFx]: can't load libphp4.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-132566@lists.php.net to get a copy of this message | ||
ID: 47012
Updated by: derick@php.net
Reported By: bulbapeppe at yahoo dot it
-Status: Open
+Status: Wont fix
Bug Type: Apache related
Operating System: solaris 10
PHP Version: 5.2.8
New Comment:
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.
.
Previous Comments:
------------------------------------------------------------------------
[2009-01-05 16:48:15] bulbapeppe at yahoo dot it
Description:
------------
I have to start apache, but the command
LoadModule php4_module
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so
gives me the following problem:
Syntax error on line 28 of
/sunrm20/dati/edudbmgr/EDUDB/apache/conf/httpd.conf:
Cannot load
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so into
server: ld.so.1: httpd: fatal: relocation error: file
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so:
symbol ap_group_id: referenced symbol not found
./apachectl start: httpd could not be started
I would like to know two things:
1- shall I have a php installed ?
2- I've checked the bugs #14147, #6667 and #4179 but they aren't so
clear.
What shall I do?
Thanks,
bulbapeppe
Expected result:
----------------
no errors
Actual result:
--------------
Syntax error on line 28 of
/sunrm20/dati/edudbmgr/EDUDB/apache/conf/httpd.conf:
Cannot load
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so into
server: ld.so.1: httpd: fatal: relocation error: file
/sunrm20/dati/edudbmgr/EDUDB/apache/libexec/solaris_2.8/libphp4.so:
symbol ap_group_id: referenced symbol not found
./apachectl start: httpd could not be started
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=47012&edit=1