#47975 [Fbk->Opn]: OpenSSL does not load
| From: | tom at brainscanmedia dot com | Date: | Wed, 15 Apr 2009 21:26:24 +0000 |
| Subject: | #47975 [Fbk->Opn]: OpenSSL does not load | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-135854@lists.php.net to get a copy of this message | ||
ID: 47975
User updated by: tom at brainscanmedia dot com
Reported By: tom at brainscanmedia dot com
-Status: Feedback
+Status: Open
Bug Type: Unknown/Other Function
Operating System: Windows 2003 Server
PHP Version: 5.2.9
New Comment:
I did as you said and I got this:
C:\PHP>php.exe -d extension_dir=ext -d extension=php_openssl.dll -m
PHP Warning: Module 'openssl' already loaded in Unknown on line 0
[PHP Modules]
bcmath
calendar
com_dotnet
ctype
curl
date
dom
filter
ftp
gd
hash
iconv
json
libxml
mbstring
mcrypt
mysql
odbc
openssl
pcre
PDO
pdo_sqlite
Reflection
session
SimpleXML
SPL
SQLite
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zlib
[Zend Modules]
C:\PHP>
Previous Comments:
------------------------------------------------------------------------
[2009-04-15 21:20:46] pajoye@php.net
no idea, it works just fine here (on ten different servers).
Simply try, using the command line, the following commands:
cd c:\php5 (or where you have php)
php.exe -d extension_dir=ext -d extension=php_openssl.dll -m
------------------------------------------------------------------------
[2009-04-15 21:16:16] tom at brainscanmedia dot com
Yes its in my path and everything is setup correctly. That link has a
phpMailer call at the top so you will see the error I get. I even tried
to reload the old php version and same thing. Can there maybe be a
conflict with any of the other dll's?
------------------------------------------------------------------------
[2009-04-15 21:14:30] pajoye@php.net
phpinfo does not do any connection. Did you enable it in your php.ini?
Are the openssl DLL in your path?
------------------------------------------------------------------------
[2009-04-15 21:09:50] tom at brainscanmedia dot com
Description:
------------
Hey not sure if this is a bug or not but none of your documents help my
situation. I just installed the latest version of PHP to see if it
works
but OpenSSL mod does not load even though I uncommented it. Here is a
link to a sample script that shows my info
http://www.stoneystraps.com/!Admin/1.php
Reproduce code:
---------------
SMTP -> ERROR: Failed to connect to server: Unable to find the socket
transport "ssl" - did you forget to enable it when you configured PHP?
(24)
SMTP Error: Could not connect to SMTP host.
Expected result:
----------------
Mail Sent (phpMailer)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=47975&edit=1