Bug #18284 Updated: Compiling with sybase-ct fails
| From: | chutney_man at hotmail dot com | Date: | Thu, 11 Jul 2002 22:36:53 +0000 |
| Subject: | Bug #18284 Updated: Compiling with sybase-ct fails | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-13890@lists.php.net to get a copy of this message | ||
ID: 18284
Updated by: chutney_man@hotmail.com
Reported By: chutney_man@hotmail.com
Status: Feedback
Bug Type: Sybase-ct (ctlib) related
Operating System: Mandrake 8.2
PHP Version: 4.2.1
New Comment:
here's the error from Apache...
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/opt/sybase/lib/libcs.so: undefined symbol: comn_free
/usr/local/apache/bin/apachectl start: httpd could not be started
and all that is on line 205 of httpd.conf is of course LoadModule
php4_module libexec/libphp4.so
Previous Comments:
------------------------------------------------------------------------
[2002-07-11 16:54:57] sniper@php.net
You should not try compile BOTH of them the same time..
Please try with fresh sources of PHP and don't put
that --with-sybase into the configure line.
And then if it fails to load, give us the whole error message. Tiny
part of it is useless.
------------------------------------------------------------------------
[2002-07-11 16:49:41] chutney_man@hotmail.com
[root@spider root]# ./configure --with-apxs=/usr/local/apache/bin/apxs
--enable-force-cgi-redirect --enable-calendar --with-sybase=/opt/sybase
--with-sybase-ct=/opt/sybase --with-mysql --with-pgsql
/root/php-4.2.1/ext/sybase_ct/.libs/libsybase_ct.al(php_sybase_ct.lo):
In function `zm_deactivate_sybase':
/root/php-4.2.1/ext/sybase_ct/php_sybase_ct.c:367: multiple definition
of `zm_deactivate_sybase'
/root/php-4.2.1/ext/sybase/.libs/libsybase.al(php_sybase_db.lo):/root/php-4.2.1/ext/sybase/php_sybase_db.c:296:
first defined here
/root/php-4.2.1/ext/sybase_ct/.libs/libsybase_ct.al(php_sybase_ct.lo):
In function `zm_info_sybase':
/root/php-4.2.1/ext/sybase_ct/php_sybase_ct.c:1662: multiple definition
of `zm_info_sybase'
/root/php-4.2.1/ext/sybase/.libs/libsybase.al(php_sybase_db.lo):/root/php-4.2.1/ext/sybase/php_sybase_db.c:1372:
first defined here
/usr/bin/ld: Warning: size of symbol `zm_info_sybase' changed from 351
to 180 in php_sybase_ct.lo
collect2: ld returned 1 exit status
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/root/php-4.2.1'
make: *** [all-recursive] Error 1
If i remove --with-sybase=/opt/sybase, it compiles ok but then apache
cannot load the module...
says something about comn_*** not being recognized
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18284&edit=1