Bug #18284 Updated: Compiling with sybase-ct fails
| From: | chutney_man at hotmail dot com | Date: | Fri, 12 Jul 2002 23:17:56 +0000 |
| Subject: | Bug #18284 Updated: Compiling with sybase-ct fails | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-14032@lists.php.net to get a copy of this message | ||
ID: 18284
Updated by: chutney_man@hotmail.com
Reported By: chutney_man@hotmail.com
Status: Bogus
Bug Type: Sybase-ct (ctlib) related
Operating System: Mandrake 8.2
PHP Version: 4.2.1
New Comment:
No reason not to document it
Previous Comments:
------------------------------------------------------------------------
[2002-07-12 18:13:16] sniper@php.net
Obviously this wasn't any bug in PHP..
------------------------------------------------------------------------
[2002-07-12 16:01:42] chutney_man@hotmail.com
Ahh.. GOT IT!
need to make a link to libinsck.so.12.5.0 called simply libinsck.so in
/opt/sybase/lib/, then change the libintl.so link in /usr/lib to point
to /opt/sybase/lib/libintl.so
then make & install...
------------------------------------------------------------------------
[2002-07-12 09:11:35] chutney_man@hotmail.com
Just tried it.. same problem. Any other ideas?
------------------------------------------------------------------------
[2002-07-11 21:59:53] sniper@php.net
Do you have /opt/sybase/lib in your /etc/ld.so.conf file?
If not, add it, and run /sbin/ldconfig
------------------------------------------------------------------------
[2002-07-11 18:36:52] chutney_man@hotmail.com
here's the error from Apache...
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/opt/sybase/lib/libcs.so: undefined symbol: comn_free
/usr/local/apache/bin/apachectl start: httpd could not be started
and all that is on line 205 of httpd.conf is of course LoadModule
php4_module libexec/libphp4.so
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18284
--
Edit this bug report at http://bugs.php.net/?id=18284&edit=1