#48715 [Fbk->Opn]: Configure php with mysql result "configure: error: mysql configure failed"
| From: | amiroot at yahoo dot com | Date: | Tue, 30 Jun 2009 01:54:23 +0000 |
| Subject: | #48715 [Fbk->Opn]: Configure php with mysql result "configure: error: mysql configure failed" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-138968@lists.php.net to get a copy of this message | ||
ID: 48715
User updated by: amiroot at yahoo dot com
Reported By: amiroot at yahoo dot com
-Status: Feedback
+Status: Open
Bug Type: MySQL related
Operating System: RedHat EL5 64bit
PHP Version: 5.2.10 / 5.3 CVS
New Comment:
Same result even I added --with-zlib-dir. So do the error in
config.log.
I think the problem is that the configure cannot find the library in
xx/lib64/mysql folder even I removed the one in xx/lib64/mysql. Can we
have an option to specify the location of the library? Because in some
case the 32 bit and 64 bit version library may coexists for
compatibility sake.
And I believe I'm not alone. I found a very similar bug before
(http://bugs.php.net/bug.php?id=47972). I open this bug because I can't
reopen that bug. I believed that the 2 case might be merged.
Previous Comments:
------------------------------------------------------------------------
[2009-06-29 20:40:39] jani@php.net
And did you try adding the obvious I omitted? (--with-zlib-dir..)
I find it kinda hard to believe this would be any PHP bug since the
config.m4 in ext/mysql has not changed between 5.2.9 and 5.2.10.
------------------------------------------------------------------------
[2009-06-29 12:04:12] amiroot at yahoo dot com
Here you go~
checking for mysql_close in -lmysqlclient... no
checking for mysql_errno in -lmysqlclient... no
configure: error: Try adding --with-zlib-dir=<DIR>. Please check
config.log for more information.
The same "cannot find -lmysqlclient" error appear in config.log
------------------------------------------------------------------------
[2009-06-29 11:57:24] jani@php.net
Try this instead:
# rm config.cache
# ./configure --disable-all --with-mysql
------------------------------------------------------------------------
[2009-06-29 11:17:50] amiroot at yahoo dot com
I tried even ./configure --with-mysql --with-zlib-dir=/usr but the
problem still exists.
------------------------------------------------------------------------
[2009-06-29 09:42:12] jani@php.net
1. Change to prefork MPM in Apache
2. Try again.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/48715
--
Edit this bug report at http://bugs.php.net/?id=48715&edit=1