ID: 48715
User updated by: amiroot at yahoo dot com
Reported By: amiroot at yahoo dot com
-Status: Feedback
+Status: Open
Bug Type: MySQL related
Operating System: RedHat EL5 64bit
PHP Version: 5.2.10 / 5.3 CVS
New Comment:
Sorry I recalled how I did it. I used to installed only 64bit version
and make a symlink of /usr/lib64/mysql to /usr/lib/mysql. Once I removed
the symlink and install the 32bit the configure got failed. Once I
removed the 32bit and create a symlink again it works :p
FYI I installed the mysql libraries through RPM.
Previous Comments:
------------------------------------------------------------------------
[2009-06-30 08:23:52] jani@php.net
You did what now to the libs? Please try installing mysql properly. I
doubt you can't build 5.2.9 either now. I have Centos5 with properly
installed mysql libs and everything work just fine.
------------------------------------------------------------------------
[2009-06-30 01:54:22] amiroot at yahoo dot com
Same result even I added --with-zlib-dir. So do the error in
config.log.
I think the problem is that the configure cannot find the library in
xx/lib64/mysql folder even I removed the one in xx/lib64/mysql. Can we
have an option to specify the location of the library? Because in some
case the 32 bit and 64 bit version library may coexists for
compatibility sake.
And I believe I'm not alone. I found a very similar bug before
(http://bugs.php.net/bug.php?id=47972). I open this bug because I can't
reopen that bug. I believed that the 2 case might be merged.
------------------------------------------------------------------------
[2009-06-29 20:40:39] jani@php.net
And did you try adding the obvious I omitted? (--with-zlib-dir..)
I find it kinda hard to believe this would be any PHP bug since the
config.m4 in ext/mysql has not changed between 5.2.9 and 5.2.10.
------------------------------------------------------------------------
[2009-06-29 12:04:12] amiroot at yahoo dot com
Here you go~
checking for mysql_close in -lmysqlclient... no
checking for mysql_errno in -lmysqlclient... no
configure: error: Try adding --with-zlib-dir=<DIR>. Please check
config.log for more information.
The same "cannot find -lmysqlclient" error appear in config.log
------------------------------------------------------------------------
[2009-06-29 11:57:24] jani@php.net
Try this instead:
# rm config.cache
# ./configure --disable-all --with-mysql
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/48715--
Edit this bug report at http://bugs.php.net/?id=48715&edit=1