ID: 48775
Updated by: jani@php.net
Reported By: alexander at sulfrian dot net
-Status: Open
+Status: Feedback
Bug Type: Streams related
Operating System: Linux
PHP Version: 5.2.10
New Comment:
What scripts..? When you install PHP from sources, any existing ini
files ARE NOT TOUCHED. Did you use some RPM or what?
Previous Comments:
------------------------------------------------------------------------
[2009-07-02 13:22:13] alexander at sulfrian dot net
Description:
------------
Hi,
I updated recently to php-5.2.10 and some scripts are not working
anymore. The scripts added some elements to the include_path. While
including some files from the include_path php echos the error that it
cannot resolve the host name. I think that this error is caused by the
change, that stream wrappers could be used in the include path and the
PATH_SEPERATOR and the stream wrappers collidate.
Downgrading to php-5.2.9-r2 solves the problem again.
Actual result:
--------------
[02-Jul-2009 13:21:47] PHP Warning: require() [<a
href='function.require'>function.require</a>]: Couldn't resolve host
name in <file> on line <line>
[02-Jul-2009 13:21:47] PHP Warning: require(rcube_user.php) [<a
href='function.require'>function.require</a>]: failed to open stream:
operation failed in <file> on line <line>
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=48775&edit=1