#48775 [Fbk->Opn]: php-5.2.10 treats include_path as url/hostname
| From: | alexander at sulfrian dot net | Date: | Fri, 03 Jul 2009 08:59:54 +0000 |
| Subject: | #48775 [Fbk->Opn]: php-5.2.10 treats include_path as url/hostname | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-139193@lists.php.net to get a copy of this message | ||
ID: 48775
User updated by: alexander at sulfrian dot net
Reported By: alexander at sulfrian dot net
-Status: Feedback
+Status: Open
Bug Type: Streams related
Operating System: Linux
PHP Version: 5.2.10
New Comment:
Noticed while trying to install roundcube webmail 0.2.0. I just tried
to create a minimal testing script and didn't get it.
One strange thing is, that if i call the script via php cli from shell,
it is working. Don't know how i could debug it. roundcube using the
__autoload function and all includes seems to be ok. Is there any
possibility to echo the hostname, that could not be resolved if such
error occur?
I am using Gentoo Linux and so installed php from source via the
portage system of gentoo. I not changed the config and so used the
original that is installed by gentoo. (Do not know if it is 100%
identical to the original from the php source package.)
Previous Comments:
------------------------------------------------------------------------
[2009-07-02 15:17:23] jani@php.net
What scripts..? When you install PHP from sources, any existing ini
files ARE NOT TOUCHED. Did you use some RPM or what?
------------------------------------------------------------------------
[2009-07-02 13:22:13] alexander at sulfrian dot net
Description:
------------
Hi,
I updated recently to php-5.2.10 and some scripts are not working
anymore. The scripts added some elements to the include_path. While
including some files from the include_path php echos the error that it
cannot resolve the host name. I think that this error is caused by the
change, that stream wrappers could be used in the include path and the
PATH_SEPERATOR and the stream wrappers collidate.
Downgrading to php-5.2.9-r2 solves the problem again.
Actual result:
--------------
[02-Jul-2009 13:21:47] PHP Warning: require() [<a
href='function.require'>function.require</a>]: Couldn't resolve host
name in <file> on line <line>
[02-Jul-2009 13:21:47] PHP Warning: require(rcube_user.php) [<a
href='function.require'>function.require</a>]: failed to open stream:
operation failed in <file> on line <line>
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=48775&edit=1