#49137 [NEW]: cannot start apache2 which php 5.3.0 installed
| From: | shlomit dot afgin at weizmann dot ac dot il | Date: | Sun, 02 Aug 2009 10:59:42 +0000 |
| Subject: | #49137 [NEW]: cannot start apache2 which php 5.3.0 installed | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-140575@lists.php.net to get a copy of this message | ||
From: shlomit dot afgin at weizmann dot ac dot il
Operating system: Red Hat Enterprise Linux AS rele
PHP version: 5.3.0
PHP Bug Type: Apache2 related
Bug description: cannot start apache2 which php 5.3.0 installed
Description:
------------
I tried to upgrade to php 5.3.0 but after 'make install' apache cannot
start anymore and I had to recover the previos version of php.
Expected result:
----------------
I tried to upgrade to php 5.3.0. I have apache 2 which compiled with
Apache/2.2.6 (Unix) mod_ssl/2.2.6 PHP/5.2.4 mod_python/3.3.1 Python/2.4.4
mod_perl/2.0.3 Perl/v5.8.5
I did:
(*) ./configure --with-apxs2=/path1/apxs --with-mysql=/path2/mysql
--with-gd=/path2 --with-jpeg-dir=/path2 --with-png-dir=/path2
--with-freetype-dir --with-zlib-dir --with-libxml-dir=/path2
--enable-gd-native-ttf --enable-mbstring --enable-zip
--with-ldap=/path2/openldap
(*) In 'make test' I got:
Tests failed : 63 ( 0.6%) ( 0.8%)
(*) In make install, between the copies I got the error:
Installing PEAR environment: /usr/local/lib/php/
pear/pear dependency package "pear/Archive_Tar" installed version 1.3.3 is
not the recomme
nded version 1.3.2, but may be compatible, use --force to install
pear/Archive_Tar cannot be installed, conflicts with installed packages
(*) The apache stop running and I got the following errors in the error
log file:
[Sun Aug 02 11:08:16 2009] [notice] SIGHUP received. Attempting to
restart
[Sun Aug 02 11:08:16 2009] [notice] seg fault or similar nasty error
detected in the paren
t process
[Sun Aug 02 11:08:54 2009] [warn] Init: Session Cache is not configured
[hint: SSLSessionC
ache]
[Sun Aug 02 11:08:54 2009] [notice] Digest: generating secret for digest
authentication ..
.
[Sun Aug 02 11:08:54 2009] [notice] Digest: done
PHP Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3
and greater in Unk
nown on line 0
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and
greater in Unknown
on line 0
[Sun Aug 02 11:08:58 2009] [warn] Init: Session Cache is not configured
[hint: SSLSessionC
ache]
[Sun Aug 02 11:08:58 2009] [notice] Digest: generating secret for digest
authentication ..
.
[Sun Aug 02 11:08:58 2009] [notice] Digest: done
(*) I recover the previos version of php and everything continue running.
How can I install php 5.3.0 successfuly?
Shlomit.
--
Edit bug report at http://bugs.php.net/?id=49137&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=49137&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=49137&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=49137&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=49137&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=49137&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=49137&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=49137&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=49137&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=49137&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=49137&r=support
Expected behavior: http://bugs.php.net/fix.php?id=49137&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=49137&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=49137&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=49137&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=49137&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=49137&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=49137&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=49137&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=49137&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=49137&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=49137&r=mysqlcfg