Bug #18301 Updated: crash in ./zend_execute.c:1598
| From: | sniper@php.net | Date: | Mon, 15 Jul 2002 10:48:40 +0000 |
| Subject: | Bug #18301 Updated: crash in ./zend_execute.c:1598 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-14192@lists.php.net to get a copy of this message | ||
ID: 18301
Updated by: sniper@php.net
Reported By: pailloncy@ifrance.com
-Status: Open
+Status: Feedback
Bug Type: Reproducible crash
Operating System: Solaris 2.5.1
-PHP Version: 4.2.1
+PHP Version: 4.3.0-dev
New Comment:
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2002-07-15 06:43:25] pailloncy@ifrance.com
Test of http://snaps.php.net/php4-latest.tar.gz
#@&" of __eprintf in libgcc that is not configured, and
apache refuse to start with error :
--------------------------------------------------
Syntax error on line 176 of /tdsi2/apache/conf/httpd.conf:
Cannot load /tdsi2/apache/libexec/libphp4.so into server:
ld.so.1: /tdsi2/apache/bin/httpd: fatal: relocation error:
file /tdsi2/apache/libexec/libphp4.so: symbol __eprintf:
referenced symbol not found
/tdsi2/apache/bin/apachectl start: httpd could not be
started
--------------------------------------------------
Add -lgcc to EXTRALIB is ok.
Otherwise, again 'child seg fault' : no fix.
------------------------------------------------------------------------
[2002-07-14 07:48:22] sniper@php.net
Can you provide a gdb backtrace of the crash when using
the latest snapshot?
------------------------------------------------------------------------
[2002-07-14 07:28:25] pailloncy@ifrance.com
Test of http://snaps.php.net/php4-latest.tar.gz
#@&" of __eprintf in libgcc that is not configured, and
apache refuse to start with error :
--------------------------------------------------
Syntax error on line 176 of /tdsi2/apache/conf/httpd.conf:
Cannot load /tdsi2/apache/libexec/libphp4.so into server:
ld.so.1: /tdsi2/apache/bin/httpd: fatal: relocation error:
file /tdsi2/apache/libexec/libphp4.so: symbol __eprintf:
referenced symbol not found
/tdsi2/apache/bin/apachectl start: httpd could not be
started
--------------------------------------------------
Add -lgcc to EXTRALIB is ok.
Otherwise, again 'child seg fault' : no fix.
------------------------------------------------------------------------
[2002-07-13 22:55:30] sniper@php.net
Try this snapshot:
http://snaps.php.net/php4-latest.tar.gz
------------------------------------------------------------------------
[2002-07-13 06:59:26] pailloncy@ifrance.com
In the widely use phpMyadmin the following files crash :
- in the version 2.2.0 : db_details.php
- in the version 2.3.0rc2 : db_details_structure.php,
tbl_properties_structure.php
and may be some other files.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18301
--
Edit this bug report at http://bugs.php.net/?id=18301&edit=1