Bug #18301 Updated: crash in ./zend_execute.c:1598
| From: | pailloncy at ifrance dot com | Date: | Mon, 15 Jul 2002 11:02:44 +0000 |
| Subject: | Bug #18301 Updated: crash in ./zend_execute.c:1598 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-14193@lists.php.net to get a copy of this message | ||
ID: 18301
Updated by: pailloncy@ifrance.com
Reported By: pailloncy@ifrance.com
-Status: Feedback
+Status: Open
Bug Type: Reproducible crash
Operating System: Solaris 2.5.1
PHP Version: 4.3.0-dev
New Comment:
Sorry to have submit twice, the same info.
I hit reload on an old page.
Now, the backtrace:
#0 0xef5824b4 in _mp_move () from /usr/lib/libmp.so.1
#1 0xef5822dc in pow () from /usr/lib/libmp.so.1
#2 0xee7a1678 in zif_pow (ht=2, return_value=0x43a4b0,
this_ptr=0x0,
return_value_used=1)
at
/tmpdsk/install/php/php4-200207140000/ext/standard/math.c:4
44
#3 0xee8a7cfc in execute (op_array=0x3b2a28)
at
/tmpdsk/install/php/php4-200207140000/Zend/zend_execute.c:1
587
#4 0xee8a7ffc in execute (op_array=0x379f60)
at
/tmpdsk/install/php/php4-200207140000/Zend/zend_execute.c:1
627
#5 0xee88d8e4 in zend_execute_scripts (type=8, retval=0x0,
file_count=3)
at
/tmpdsk/install/php/php4-200207140000/Zend/zend.c:810
#6 0xee8382ac in php_execute_script
(primary_file=0xeffff810)
at
/tmpdsk/install/php/php4-200207140000/main/main.c:1390
#7 0xee8ae9e4 in apache_php_module_main (r=0x3598b0,
display_source_mode=0)
at
/tmpdsk/install/php/php4-200207140000/sapi/apache/sapi_apac
he.c:55
#8 0xee8b0004 in send_php (r=0x3598b0,
display_source_mode=0,
filename=0x35a648
"/web/www-isis.enst.fr/site/Admin/phpMyAdmin230rc2/db_detai
ls_structure.php")
at
/tmpdsk/install/php/php4-200207140000/sapi/apache/mod_php4.
c:550
#9 0xee8b0088 in send_parsed_php (r=0x3598b0)
at
/tmpdsk/install/php/php4-200207140000/sapi/apache/mod_php4.
c:565
#10 0x0001d490 in ap_invoke_handler ()
#11 0x0003176c in process_request_internal ()
#12 0x00031b0c in ap_process_request ()
#13 0x00028324 in child_main ()
#14 0x00028588 in make_child ()
#15 0x00028c78 in standalone_main ()
#16 0x00029648 in main ()
Previous Comments:
------------------------------------------------------------------------
[2002-07-15 06:48:39] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
------------------------------------------------------------------------
[2002-07-15 06:43:25] pailloncy@ifrance.com
Test of http://snaps.php.net/php4-latest.tar.gz
#@&" of __eprintf in libgcc that is not configured, and
apache refuse to start with error :
--------------------------------------------------
Syntax error on line 176 of /tdsi2/apache/conf/httpd.conf:
Cannot load /tdsi2/apache/libexec/libphp4.so into server:
ld.so.1: /tdsi2/apache/bin/httpd: fatal: relocation error:
file /tdsi2/apache/libexec/libphp4.so: symbol __eprintf:
referenced symbol not found
/tdsi2/apache/bin/apachectl start: httpd could not be
started
--------------------------------------------------
Add -lgcc to EXTRALIB is ok.
Otherwise, again 'child seg fault' : no fix.
------------------------------------------------------------------------
[2002-07-14 07:48:22] sniper@php.net
Can you provide a gdb backtrace of the crash when using
the latest snapshot?
------------------------------------------------------------------------
[2002-07-14 07:28:25] pailloncy@ifrance.com
Test of http://snaps.php.net/php4-latest.tar.gz
#@&" of __eprintf in libgcc that is not configured, and
apache refuse to start with error :
--------------------------------------------------
Syntax error on line 176 of /tdsi2/apache/conf/httpd.conf:
Cannot load /tdsi2/apache/libexec/libphp4.so into server:
ld.so.1: /tdsi2/apache/bin/httpd: fatal: relocation error:
file /tdsi2/apache/libexec/libphp4.so: symbol __eprintf:
referenced symbol not found
/tdsi2/apache/bin/apachectl start: httpd could not be
started
--------------------------------------------------
Add -lgcc to EXTRALIB is ok.
Otherwise, again 'child seg fault' : no fix.
------------------------------------------------------------------------
[2002-07-13 22:55:30] sniper@php.net
Try this snapshot:
http://snaps.php.net/php4-latest.tar.gz
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18301
--
Edit this bug report at http://bugs.php.net/?id=18301&edit=1