#49678 [Opn->Fbk]: .msi install screws up Apache httpd.conf
| From: | jmertic@php.net | Date: | Wed, 30 Sep 2009 13:48:59 +0000 |
| Subject: | #49678 [Opn->Fbk]: .msi install screws up Apache httpd.conf | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-143083@lists.php.net to get a copy of this message | ||
ID: 49678
Updated by: jmertic@php.net
Reported By: adept at accutek dot net
-Status: Open
+Status: Feedback
Bug Type: Windows Installer
Operating System: XP
PHP Version: 5.2.11
-Assigned To:
+Assigned To: jmertic
New Comment:
Please provide an error log of the installer and a copy of your
httpd.conf file after the install. You can generate the error log using
the following command:
msiexec /i php-5.2.11-win32-installer.msi /l*v error.txt
It sounds like you are choosing a complete install, and pushing in all
of the Apache config options.
Previous Comments:
------------------------------------------------------------------------
[2009-09-26 01:38:36] adept at accutek dot net
Description:
------------
The php-5.2.11-win32-installer.msi installer creates multiple lines for
PHPINIDir and module php5_module which stop the attempt to START Apache
2.2.13.
Cleaning up the httpd.conf file manually (deleteing dups) leave the
file in some sort of unstable state. When I attempt to start Apache, I
get dropped into VS as a Debugger.
If I remove (uninstall) php, Apache runs fine.
I have duplicated this 3 times now.
I'm a newbie so I hope this is sufficient info.
PS: I Did check the bug archives, but this previous report was marked
as 'bogus' and no solution given
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=49678&edit=1