#50140 [NEW]: With default compilation option, php symbols are unresolved for nsapi sapi
| From: | basant dot kukreja at gmail dot com | Date: | Tue, 10 Nov 2009 18:46:36 +0000 |
| Subject: | #50140 [NEW]: With default compilation option, php symbols are unresolved for nsapi sapi | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-144420@lists.php.net to get a copy of this message | ||
From: basant dot kukreja at gmail dot com
Operating system: Linux
PHP version: 5.3SVN-2009-11-10 (SVN)
PHP Bug Type: *General Issues
Bug description: With default compilation option, php symbols are unresolved for nsapi sapi
Description:
------------
On Fedora 11, by default gcc uses
"-fvisibility=hidden", When we compile it for Sun Web Server using
following
configure options, php compiles fine.
'./configure' '--with-nsapi=<server_path>' '--with-zlib'
'--prefix=/usr/local'
But when we start the web server, we get the following error :
failure: CORE2253: Error running Init function load-modules: dlsym for
php5_init failed (<path>/lib/libphp5.so: undefined symbol: php5_init)
failure: server initialization failed
Expected result:
----------------
Server should be able to load php correctly.
Actual result:
--------------
Sun Web Server fails to start because of unexported symbols.
--
Edit bug report at http://bugs.php.net/?id=50140&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=50140&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=50140&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=50140&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=50140&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=50140&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=50140&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=50140&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=50140&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=50140&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=50140&r=support
Expected behavior: http://bugs.php.net/fix.php?id=50140&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=50140&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=50140&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=50140&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=50140&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=50140&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=50140&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=50140&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=50140&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=50140&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=50140&r=mysqlcfg